在线检测未来函数

通达信周KDJ指标公式

来源:Internet,编辑:股旁网,2012-11-14

周J:EMA("KDJ.J#WEEK"(9,2,5),5),COLORFF9900;
周K:EMA("KDJ.K#WEEK"(9,2,5),5),COLOR0000FF,LINETHICK1;
周D:EMA("KDJ.D#WEEK"(9,2,5),5),COLOR00FF00,LINETHICK1;
CG:=(周J>REF(周J,1)) AND 周J>-20;
DIFF :EMA( EMA(CLOSE,12) - EMA(CLOSE,26),3),COLOR0000FF,NODRAW;
DEA : EMA(DIFF,9),COLOR00FF00,NODRAW;
MACD : 2*(DIFF-DEA),NODRAW;
STICKLINE(CG,-30,100,4,0),COLOR804000;
周:=周J-REF(周J,1) ;
STICKLINE(周>0 AND 周J>-20,周*2,0,6,0),COLOR0598FF;
STICKLINE(周<0 AND 周J>-20,周*2,0,6,0),COLORFF9900;
NOTEXT1:周J,COLORFF9900;
NOTEXT2:周K,COLOR0000FF;
NOTEXT3:周D,COLOR00FF00;
NOTEXT4:IF(CG,周J,DRAWNULL),COLORRED,LINETHICK3;
DRAWTEXT(CROSS(周K,周D),周K*1.15,'金叉'),COLOR0077FF,LINETHICK2;
DRAWTEXT(CROSS(周K,周D),周K*1,'▲'),LINETHICK3,COLOR0000FF;
DRAWTEXT(CROSS(周D,周K),周K*0.98,'死叉'),COLOR00FF00,LINETHICK2;
DRAWTEXT(CROSS(周D,周K),周K*1.15,'▼'),LINETHICK3,COLOR00FF00;
NOTEXT5:IF(MACD>0,-20,DRAWNULL),LINETHICK3,COLORRED;
NOTEXT6:IF(MACD<0,-20,DRAWNULL),LINETHICK3,COLORYELLOW;

通达信周KDJ指标公式

 

相关文章