在线检测未来函数

通达信换手操盘线主图指标公式

来源:Internet,编辑:股旁网,2012-12-07

下降通道股价无资金控盘则无黄线,rsi操盘也无买入提示,可抑制操底冲动,冲动是魔鬼

M1:=10;
N1:SUMBARS(V,CAPITAL*0.25),NODRAW;
N2:SUMBARS(V,CAPITAL*2),NODRAW;
N3:2*EMA(C,N1)-EMA(C,N2),COLORDD8758;
N4:EMA(N3,5),COLOR1318FF;
持股:IF(MA(N3,1)>REF(MA(N3,1),1),MA(N3,1),DRAWNULL),COLORYELLOW,LINETHICK2;
EMA13:=EMA(C,13),COLOR0000FF;
EMA34:=EMA(C,34),COLORYELLOW;
EMA55:=EMA(C,55),COLORFF00FF;
EMA120:=EMA(C,120),COLORFFCC66;
AR1:=EMA55>EMA34 AND EMA34>EMA13;
AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);
AR3:=EMA13>=REF(EMA13,2);
AR4:=COUNT(CROSS(C,EMA13),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
DRAWTEXT(AR6,L-0.25,'杏'),COLOR00CCFF;
STICKLINE(AR6,H,L,0.5,1),COLOR00CCFF;
STICKLINE(AR6,O,C,6,1),LINETHICK2,COLOR00CCFF;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),M1,1)/SMA(ABS(CLOSE-LC),M1,1)*100,COLOR9900FF;
DRAWTEXT(CROSS(RSI1,80),(HIGH * 1.1),'卖'),COLORYELLOW;
DRAWICON(CROSS(RSI1,80),(HIGH)*(1.02),2);
DRAWTEXT(CROSS(RSI1,50),L-1.08,'买'),COLORRED;
DRAWICON(CROSS(RSI1,50),L-0.58,1);
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'顶'),COLOR1880FF;
RSV11:=(C - LLV(LOW,27))/(HHV(HIGH,3) - LLV(LOW,27)) * 100;
F := SMA(RSV11, 3, 1);
K1 := SMA(F,3, 1);
D1 := SMA(K1,3, 1);
WAV:=3*K1-2*D1;
A11:=IF(1,C,IF(C<REF(O,1) AND L<REF(L,1),L,C));
A12:=IF(C<REF(L,1),L,A11);
A13:=IF(H<REF(O,1),L,A12);
A14:=IF(O<=REF(C,1) AND C<REF(O,1),L,A13);
A:=IF(C<O AND O<REF(O,1) AND L<REF(L,1),L,A14);
AJ1:=ATAN((A/REF(A,1)-1)*100)*180/3.1416;
LJIAO:=ATAN((VOL/REF(VOL,1)-1)*100)*180/3.1416;
DSLJ:=LJIAO>0 AND ABS(LJIAO-AJ1)<30;
JIA5:=WAV-REF(WAV,4)>50;
DSALE:=DSLJ AND (JIA5 OR WAV>90);
DILJ:=LJIAO<0 AND ABS(LJIAO-AJ1)<30;
JIA6:=WAV-REF(WAV,4)<-50;
DBUY:=DILJ AND (JIA6 OR WAV<10);
PLX:=((C-MA(C,10))/MA(C,10)+(C-MA(C,5))/MA(C,5))*100;
DING1:=PLX>25;
DI1:=PLX<-25;
跌幅:=(C-HHV(C,10))/HHV(C,10)*100;
DI2:=跌幅<-20;
涨幅:=(C-LLV(C,10))/LLV(C,10)*100;
DING2:=涨幅>20;
DING:=DSALE OR DING2;
DI:=DBUY OR DI1 OR DI2;
QSA:=(MA(C,60)-REF(MA(C,60),10))/REF(MA(C,60),10)*100;
QS:=SMA(QSA,10,1);
DS:=QS<-3 OR MA(C,60)<REF(MA(C,60),1);
QC:=DS AND DING AND DING!=REF(DING,1);
DRAWTEXT(QC,H*1.05,'◇'),COLORRED;
DRAWTEXT(QC,H*1.15,'做空'),COLORRED;

通达信换手操盘线主图指标公式

 

相关文章