在线检测未来函数

通达信黑马回头指标公式

来源:Internet,编辑:股旁网,2012-12-14

ZF1:=15;ZF2:=3;N:=5;
QSXS:=MA(C,30)>=REF(MA(C,30),1);
ZF:=(C/REF(C,1)-1)*100;
黑马:((C/REF(C,3)-1)*100>=ZF1 AND COUNT(ZF>=ZF2,3)=3 AND QSXS)*15,COLORFF00FF,LINETHICK2;
HMSJ:=BARSLAST(黑马);
黑:IF(HMSJ<=10 AND QSXS,REF(C,HMSJ+2),0),COLORFF6600,POINTDOT,LINETHICK2;
DM1:=LOW<=REF(C,HMSJ+2) AND HMSJ<=10 AND 黑马=0;
GL1:=黑>0 AND CROSS(C,黑);
低买:(DM1>0 AND COUNT(GL1,HMSJ)=0)*黑,COLOR00FF00,LINETHICK2;
白马:((H/REF(L,4)-1)*100>=ZF1 AND COUNT(ZF>=ZF2,4)>=3 AND H=HHV(H,3) AND QSXS)*10,COLORYELLOW,STICK,LINETHICK5;
BMSJ:=BARSLAST(白马);
白:IF(BMSJ<=10 AND QSXS,REF(C,BMSJ+3),0),COLORWHITE,POINTDOT,LINETHICK2;
DM2:=LOW<REF(C,BMSJ+3) AND BMSJ<=10 AND 白马=0;
GL2:=白>0 AND CROSS(C,白);
低买1:(DM2>0 AND COUNT(GL2,BMSJ)=0)*白,COLORWHITE,LINETHICK2;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
BM:=COUNT(MA5>REF(MA5,1),N)=N AND MA5>MA10 AND MA10>MA20 AND MA20>MA30;
奔马:BM*5,COLOR0000FF,POINTDOT,LINETHICK2;
STICKLINE(奔马>0,0 ,5 ,3 ,1 ),COLOR0000FF;
BMSJ2:=BARSLAST(奔马);
BMHT:=MA5<REF(MA5,1) AND C<MA5 AND C<MA10 AND C>MA30;
饮水:(BMSJ2<=5 AND BMHT AND QSXS)*3,COLORFF6600,LINETHICK2;

通达信黑马回头指标公式

 

相关文章