在线检测未来函数

通达信神龙飞天指标公式

来源:Internet,编辑:股旁网,2012-12-22

VAR1:=(EMA(AMOUNT,5)/EMA(VOL,5)/100-EMA(AMOUNT,125)/EMA(VOL,125)/100)/(EMA(AMOUNT,5)/EMA(VOL,5)/100)<-0.4;
VAR2:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=(-100)*(HHV(HIGH,52)-CLOSE)/(HHV(HIGH,52)-LLV(LOW,52));
VAR6:=COUNT(VAR1,5)>=1 AND (VAR5<-99.9 OR VAR4<15 AND VAR3<12);
VAR7:=VOL/FINANCE(7);
VAR8:=100*WINNER(CLOSE);
VAR9:=MA(VAR8,3);
VARA:=MA(VAR7,34);
VARB:=VAR9<VARA*100 AND VAR8<VAR7;
VARC:=SUM(IF(CLOSE>REF(CLOSE,1),1,0),0);
VARD:=SUMBARS(VOL,CAPITAL);
VARE:=IF(CLOSE>LLV(CLOSE,VARD),1,-1)*IF(VARC>LLV(VARC,VARD),1,-1);
VARF:=COUNT(IF(VARE=-1,1,0)=1,8)>2;
VAR10:=(CLOSE-DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100)))/DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100))*100<-18;
VAR11:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.01;
VAR12:=VARF AND VAR10 AND VAR11;
VAR13:=VOL/CAPITAL>=0.02 AND VOL/CAPITAL<=0.2 AND OPEN=1.105;
VAR14:=VAR13 AND COUNT(VAR13,5)=1;
VAR15:=VAR12 OR VAR13;
VAR16:=REF(CLOSE,1);
VAR17:=SMA(MAX(CLOSE-VAR16,0),7,1)/SMA(ABS(CLOSE-VAR16),7,1)*100;
VAR18:=SMA(MAX(CLOSE-VAR16,0),13,1)/SMA(ABS(CLOSE-VAR16),13,1)*100;
VAR19:=VAR17<20 AND VAR18<25;
VAR1A:=VAR19;
VAR1B:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),0);
VAR1C:=IF(CLOSE>LLV(CLOSE,VARD),1,-1);
VAR1D:=IF(VAR1B>LLV(VAR1B,VARD),1,-1);
VAR1E:=VAR1C*VAR1D;
VAR1F:=IF(VAR1E=-1,1,0);
VAR20:=VAR1F AND CLOSE=LLV(CLOSE,120) AND VAR8<VAR7;
VAR21:=IF(FILTER(VAR6 AND VARB AND VAR15 AND VAR1A AND VAR20>0,4),70,0);
VAR22:=IF(VARB AND VAR1A AND VAR20>0,50,0);
持仓区: STICKLINE(CLOSE>EMA(CLOSE,20),80,85,8,1);
空仓区: STICKLINE(CLOSE<EMA(CLOSE,20),80,85,8,1);
VAR23:=HHV(HIGH,9)-LLV(LOW,9);
VAR24:=HHV(HIGH,9)-CLOSE;
VAR25:=CLOSE-LLV(LOW,9);
VAR26:=VAR24/VAR23*100-70;
VAR27:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR28:=(2*CLOSE+HIGH+LOW)/4;
VAR29:=SMA(VAR25/VAR23*100,3,1);
VAR2A:=LLV(LOW,34);
VAR2B:=SMA(VAR29,3,1)-SMA(VAR26,9,1);
VAR2C:=IF(VAR2B>100,VAR2B-100,0);
VAR2D:=HHV(HIGH,34);
VAR2E:=EMA((VAR28-VAR2A)/(VAR2D-VAR2A)*100,13);
VAR2F:=EMA(0.667*REF(VAR2E,1)+0.333*VAR2E,2);
神龙飞天: VAR2F;
STICKLINE(VAR2E-VAR2F>0,VAR2E,VAR2F,8,0),COLORRED;
STICKLINE(VAR2E-VAR2F<0,VAR2E,VAR2F,8,0),COLORGREEN;
潜龙能量: (VAR2E-VAR2F)*5;
STICKLINE(潜龙能量>=0,0,潜龙能量*1,4,0);
STICKLINE(潜龙能量>=0,0,潜龙能量*0.8,4,0);
STICKLINE(潜龙能量>=0,0,潜龙能量*0.6,4,0);
STICKLINE(潜龙能量>=0,0,潜龙能量*0.4,4,0);
STICKLINE(潜龙能量>=0,0,潜龙能量*0.2,4,0);
STICKLINE(潜龙能量<0,0,潜龙能量*1,4,0);
STICKLINE(潜龙能量<0,0,潜龙能量*0.8,4,0);
STICKLINE(潜龙能量<0,0,潜龙能量*0.6,4,0);
STICKLINE(潜龙能量<0,0,潜龙能量*0.4,4,0);
STICKLINE(潜龙能量<0,0,潜龙能量*0.2,4,0);

通达信神龙飞天指标公式

 

相关文章