在线检测未来函数

通达信短顶短底指标公式

来源:Internet,编辑:股旁网,2013-01-10

VA1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
持币区域:VA1,COLORFEDCBA;
持股区域:IF(VA1>0,VA1,0),COLORRED;
短顶:STICKLINE(VA1>9 AND FILTER(VA1<REF(VA1,1),5),VA1+2,0,3,0),COLORGREEN;
大顶:STICKLINE(VA1>20 AND FILTER(VA1<REF(VA1,1),5),VA1+5,0,7,0),COLOR00FF00;
VA2:=HHV(VA1>20,10);
危险: STICKLINE(VA2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VA1+10,0,4,0);
注意止损:STICKLINE(VA2 AND FILTER(VA1< REF(VA1,1),6)
AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VA1+6,0,3,0);
短底:STICKLINE(VA1<-9 AND VA1> REF(VA1,1),VA1-2,0,3,0),COLORRED;
大底:STICKLINE(VA1<-20 AND FILTER(VA1> REF(VA1,1),5),VA1-5,0,7,0),COLORYELLOW;{www.Gupang.com 股-旁-网}
买入准备:VA1<-9 AND VA1>REF(VA1,1),COLORWHITE;
DRAWTEXT(VA1>9 AND FILTER(VA1<REF(VA1,1),5),VA1+2,'短顶'),COLOR00FF00;
DRAWTEXT(VA1>20 AND FILTER(VA1<REF(VA1,1),5),VA1+5,'大顶'),COLORFFFF00;
DRAWTEXT(VA2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VA1+10,'危险'),COLOR00FFFF;
DRAWTEXT(VA2 AND FILTER(VA1< REF(VA1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VA1+6,'注意止损'),COLORFF00FF;
DRAWTEXT(FILTER(VA1<-9 AND VA1>REF(VA1,1),18),VA1-2,'短底'),COLOR0000FF;
DRAWTEXT(VA1<-20 AND FILTER(VA1> REF(VA1,1),5),VA1-5,'大底');
DRAWTEXT(FILTER(VA1<-9 AND VA1>REF(VA1,1),18),1,'买入准备');

通达信短顶短底指标公式

 

相关文章