在线检测未来函数

通达信BBD超准指标公式

来源:Internet,编辑:股旁网,2013-01-12

AL:=(C+L+H)/3;
AO:=SMA(AL,5,1)-SMA(AL,13,1);
BBD:(AO-SMA(AO, 3,1))*100,COLORFFCCFF,NODRAW;
BBDA:SMA(BBD,5,2),COLORRED,LINETHICK0;
RSV1:=BBD;
RSV2:=BBDA;
{BBD彩色柱体}
VAR11:=IF(DATE<1091230 AND DATE>900101,1,0);
BBD1:=IF(BBD>=REF(BBD,1)*VAR11,BBD,DRAWNULL);
BBD2:=IF(BBD<REF(BBD,1)*VAR11,BBD,DRAWNULL);
STICKLINE(BBD1,0,BBD,3,0),COLOR000088;
STICKLINE(BBD1,0,BBD,1.5,0),COLOR0000AA;
STICKLINE(BBD1,0,BBD,1,0),COLOR0000CC;
STICKLINE(BBD1,0,BBD,0.5,0),COLOR0000FF;
STICKLINE(BBD2,0,BBD,3,0),COLOR888800;
STICKLINE(BBD2,0,BBD,1.5,0),COLORAAAA00;
STICKLINE(BBD2,0,BBD,1,0),COLORCCCC00;
STICKLINE(BBD2,0,BBD,0.5,0),COLORFFFF00;
SV1:=BARSLAST(REF(CROSS(RSV1,RSV2),1));
SV1A:=REF(CLOSE,SV1+1)>CLOSE AND RSV1>REF(RSV1,SV1+1) AND
CROSS(RSV1,RSV2);
上涨BBD:IF(SV1A,RSV2,DRAWNULL),COLORRED;
DRAWTEXT(SV1A,RSV2,'─B底背'),COLOR0033FF;
SV2:=BARSLAST(REF(CROSS(RSV2,RSV1),1));
SV2A:=REF(CLOSE,SV2+1)<CLOSE AND REF(RSV1,SV2+1)>RSV1 AND CROSS(RSV2,RSV1);
下跌BBD:IF(SV2A,RSV2,DRAWNULL),COLORFFFF00;
DRAWICON(((((LLV(BBD,4) > 0) AND (BBD < REF(BBD,1)))
AND (REF(BBD,1) > REF(BBD,2))) AND (REF(BBD,2) > REF(BBD,3)))
,BBD,2);
DRAWICON(((((HHV(BBD,4) < 0) AND (BBD > REF(BBD,1)))
AND (REF(BBD,1) < REF(BBD,2))) AND (REF(BBD,2) <
REF(BBD,3))),BBD,1);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26)*10;
DEA:=EMA(DIF,9);
上涨:(DIF-DEA)*2,COLOR0000EE,LINETHICK0;
下跌:上涨,COLORCYAN,NODRAW,LINETHICK0;
VARF:=TROUGHBARS(3,15,1)<4;
多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))
/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),LINETHICK1,COLORWHITE;
STICKLINE(FILTER(VARF=1,5) AND 多空<-10,下跌,0,3.2,1),COLOR00FFFF;
STICKLINE(FILTER(VARF=1,5),下跌,0,3,0),COLORAA00AA;
STICKLINE(FILTER(VARF=1,5),下跌,0,2.3,0),COLORBB00BB;
STICKLINE(FILTER(VARF=1,5),下跌,0,1.6,0),COLORCC00CC;
STICKLINE(FILTER(VARF=1,5),下跌,0,0.9,0),COLORDD00DD;
STICKLINE(FILTER(VARF=1,5),下跌,0,0.2,0),COLOREE00EE;
明天见底:FILTER(VARF=1,3) OR CROSS(多空,0) OR CROSS(多空,10),COLORFF00FF,NODRAW;

通达信BBD超准指标公式

 

相关文章