在线检测未来函数

飞狐天地之间任我行指标公式

来源:Internet,编辑:股旁网,2013-01-14

DRAWGBK(1,colorrgb(242,254,255),colorrgb(10,15,35),1);
VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10A:=IF(MA(CLOSE,58),1,0);
cya:=EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10A;
VA1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VA2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VA3:=SMA(VA2,2,1);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX(CLOSE - LC,0),4.1,1))/(SMA(ABS(CLOSE - LC),4.1,1)));
地:sma(ABS(VA1),2,1),COLORCYAN,LINETHICK0;
春芽:if(cya<50,cya,50),COLORYELLOW,LINETHICK0;
STICKLINE(春芽>0,地-1 ,地-1+春芽*1.0,2.5,1 ),COLOR00EE55;
STICKLINE(春芽>0,地-1,地-1+春芽*0.8,3,1 ),COLOR00BB44;
STICKLINE(春芽>0,地-1,地-1+春芽*0.6,3.1,1 ),COLOR00aa33;
STICKLINE(春芽>0,地-1 ,地-1+春芽*0.4,3.3,1),COLOR009922;
STICKLINE(春芽>0,地-1,地-1+春芽*0.2,3.5,1 ),COLOR008811;
天:sma(100+(-ABS(VA1)),2,1),colorgreen,LINETHICK0;
FILLRGN(1,130,天*0.99),COLOReeaa00;
FILLRGN(1,-5,地*1.01),COLOR104a4a;
任我行:ma(SMA(VA3*SMA(RSI,2,1),2,1),2),coloreeeeee,LINETHICK2;
PARTLINE(任我行>ref(ma(任我行,3),1),任我行),linethick4,colorred;
市值:=C*CAPITAL*VOLUNIT/100000000;
流通:=FINANCE( 7)/10000;
市盈率:=DYNAINFO(39);
F:=COST(5 );J:=COST(95 );
M:=COST(15 );B:=COST(85 );
F1:=(J-F)/(F+J)*100;M1:=(B-M)/(B+M)*100;
成本集中度90:=F1;
成本集中度70:=M1;
获利盘:=WINNER(CLOSE)*100;
套牢盘:=100*(1-WINNER(C));
换手率:=vol/CAPITAL*100;
净资产:=FINANCE(34);
最新收益:=FINANCE(37);
浮筹比例:=(winner(c*1.1)-winner(c*0.9))/winner(hhv(h,0))*100;
DRAWTEXTEX(c>0,1,5,205,'市盈率:'+NUMTOSTR(市盈率,2)+' '),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c>0,1,5,305,'成本集中度90:'+NUMTOSTR(成本集中度90,2)+' '),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c>0,1,5,405,'成本集中度70:'+NUMTOSTR(成本集中度70,2)+' '),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c>0,1,5,505,'获利盘:'+NUMTOSTR(获利盘,2)+' % '),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c>0,1,5,605,'套牢盘:'+NUMTOSTR(套牢盘,2)+' % '),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c>0,1,5,705,'浮筹比例:'+NUMTOSTR(浮筹比例,2)+'% '),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c>0,1,5,80,'流通:'+NUMTOSTR(流通,2)+'亿股 '),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c>0,1,150,80,'净资产:'+NUMTOSTR(净资产,2)+' 元'),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c>0,1,320,80,'最新收益:'+NUMTOSTR(最新收益,2)+' 元'),LINETHICK1,ColorFFFFFF;
DRAWTEXTEX(c>0,1,900,80,'§长阳真人§'),LINETHICK1,ColoreeFF00;

飞狐天地之间任我行指标公式

 

相关文章