在线检测未来函数

大智慧期货价角指标公式

来源:Internet,编辑:股旁网,2013-01-26

该指标是本人在先辈的股价角度相关指标的基础上作了进一步的发展,通过分析价角5与价角20的位置与动向,使得投资安全度大大增强!

MA5:=EMA(C,5);
MA20:=EMA(C,20);
MA5角度:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
MA20角度:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;
MA20角度变化率:=ATAN((MA20角度/REF(MA20角度,1)-1)*100)*180/3.1416;
价角5:MA5角度*10,coloryellow,LINETHICK2;
价角20:MA20角度*10,colorred,linethick3;
买入线:VERTLINE(cross(价角5,价角20) , 0),colorred;
买入:cross(价角5,价角20)*50,colorred;
{www.gupang.com 股旁网_大智慧指标公式}
卖出线:VERTLINE(cross(-价角5,-价角20), 0),colorgreen;
卖出:IF(cross(-价角5,-价角20) AND 价角5<0,-50,0),colorgreen;
二十均线角变率:MA20角度变化率*3,colorffff00;
STICKLINE(CROSS(MA5角度,0) AND 二十均线角变率<0,0,500,3,0),COLORyellow;
STICKLINE((CROSS(MA5角度,MA20角度) AND MA20角度>0) OR CROSS(MA20角度,0),0,400,3,0),COLORRED;
STICKLINE(CROSS(-MA5角度,0) AND 二十均线角变率<0,0,-500,3,0),COLORFFFF00;
STICKLINE((CROSS(-MA5角度,-MA20角度) AND MA20角度<0) OR CROSS(-MA20角度,0),0,-400,3,0),COLORff00ff;
cc:0,linethick2,COLORffffff;
uu:450,linethick2,colorff00ff;

大智慧期货价角指标公式

 

相关文章