在线检测未来函数

通达信网牛线主图指标公式

来源:Internet,编辑:股旁网,2013-01-27

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
马线:=MA(牛线,8),COLORGREEN;
DRAWICON( FILTER(CROSS(牛线,马线),20),马线+0.02 ,1);
DRAWTEXT(CROSS(牛线,马线),LOW*0.98,'买'),COLORMAGENTA,LINETHICK4;
止损价:H*0.95,LINETHICK0.5,COLORMAGENTA;
庄家:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORMAGENTA;
IF(庄家>=REF(庄家,1),庄家,DRAWNULL),COLORMAGENTA,LINETHICK4;
IF(庄家<=REF(庄家,1),庄家,DRAWNULL),COLORGREEN,LINETHICK4;
【0】:=MA(L+(H-L)/2,5),CIRCLEDOT,COLORMAGENTA;
【1】:=DRAWLINE(CURRBARSCOUNT=3,【0】,CURRBARSCOUNT=2,【0】,0),COLORYELLOW,LINETHICK2;
【2】:=DRAWLINE(CURRBARSCOUNT=2,【0】,CURRBARSCOUNT=1,【0】,0),COLORRED,LINETHICK2;
【3】:=DRAWLINE(CURRBARSCOUNT=3,【0】,CURRBARSCOUNT=1,【0】,0),COLORRED,LINETHICK2;
DRAWBAND(【1】,RGB(155,50,50),【3】,RGB(250,250,0));
DRAWBAND(【2】,RGB(100,50,50),【3】,RGB(250,100,0));
【4】:=REF(【0】,1);【5】:=REF(【0】,2);
DRAWTEXT(【0】>【4】 AND 【0】<【5】,【2】,'转强'),COLOR33FFCC;
DRAWTEXT(【0】>【4】 AND 【0】>【5】,【2】,'强市'),COLOR33FFCC;
DRAWTEXT(【0】<【4】 AND 【0】>【5】,【2】,'转弱'),COLOR33FFCC;
DRAWTEXT(【0】<【4】 AND 【0】<【5】,【2】,'弱市'),COLOR33FFCC;
{主图图标公式二}
KDJ_K:="KDJ.K"(9,3,3);KDJ_D:="KDJ.D"(9,3,3);KDJ_J:="KDJ.J"(9,3,3);
买1:=CROSS(KDJ_J,0) OR (CROSS(KDJ_J,KDJ_K) AND KDJ_D<26);
买2:=CROSS("RSI.RSI1"(6,2,2),20) OR CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
买3:=CROSS("MACD.DIF","MACD.DEA") OR CROSS("MACD.MACD",0);
买0:=买1+买2+买3;
买:=IF(买0>1,买0,0);
掏底:IF(买,L*0.9978-0.03,DRAWNULL),POINTDOT,COLOR00FFFF,LINETHICK5;
选股:=FILTER(CROSS("KDJ.K","KDJ.D")&&CROSS("MACD.DIF","MACD.DEA"),50);
低吸:IF(选股,L*0.988-0.01,DRAWNULL),POINTDOT,COLORFF00FF,LINETHICK7;
ST:="MCST";
QQ:=FILTER(C>ST,22);
IF(QQ,L*0.998-0.01,DRAWNULL),POINTDOT,LINETHICK8,COLORRED;
IF(QQ,L*0.998-0.04,DRAWNULL),POINTDOT,LINETHICK8,COLOR55FF33;
IF(QQ,L*0.998-0.07,DRAWNULL),POINTDOT,LINETHICK8,COLORFF00FF;
{RSI底背}
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
IF(B3,L*0.9978-0.05,DRAWNULL),POINTDOT,COLORCYAN,LINETHICK8;
A:=(3*C+H+L+O)/6;
XJ:=(A+0.618*REF(A,1)+0.382*REF(A,2)+0.236*REF(A,3)+0.146*REF(A,4))/2.382;
YCZXH:=(MA(HHV(A,2),5)+MA(HHV(A,2),13)+MA(HHV(A,2),21)+MA(HHV(A,2),32))/4;
YCZXL:=(MA(LLV(A,2),5)+MA(LLV(A,2),13)+MA(LLV(A,2),21)+MA(LLV(A,2),32))/4;
PJ:=(10*A+9*REF(A,1)+8*REF(A,2)+7*REF(A,3)+6*REF(A,4)+5*REF(A,5)+4*REF(A,6)+3*REF(A,7)+2*REF(A,8)+REF(A,9))/55;
A1:=EMA(PJ,3),COLOR004000;A2:=EMA(PJ,5),COLOR004000;
A31:=EMA(PJ,7),COLOR004000;A4:=EMA(PJ,9),COLOR004000;
A5:=EMA(PJ,11),COLOR004000;
LX:=REF(XJ,1);
ZD:=(SMA(MAX(XJ-LX,0),5,1)/SMA(ABS(XJ-LX),5,1))*100;
KX1:=(CLOSE>=OPEN) AND ZD>=50;
KX2:=(CLOSE<OPEN) AND ZD>=50;
KX3:=(CLOSE>=OPEN) AND ZD<50;
KX4:=(CLOSE<OPEN) AND ZD<50;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BBB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:=(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股1:=PMB AND 密码>REF(密码,1) AND 二日比>1 ,COLORRED,NODRAW;
均价线:=AMOUNT/V/100;
均价线2:=MA(均价线,3);
均价线5:=MA(均价线,5);
均价线10:=MA(均价线,10);
均价线30:=MA(均价线,30);
突破1:=C>均价线2 AND 均价线2<REF(均价线2,1) AND REF(均价线2,1)<REF(均价线2,2)
AND REF(均价线2,2)<REF(均价线2,3) AND 选股;
STICKLINE(突破1,H,L,5,0),LINETHICK1,COLORRED;
STICKLINE(突破1,H,L,0.2,0),COLORYELLOW;
STICKLINE(突破1,O,C,2,0),LINETHICK1,COLORYELLOW;
STICKLINE(突破1,O,C,3,0),LINETHICK1,COLORMAGENTA;
STICKLINE(突破1,H,L,0,1),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,GNBLOCK);
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
DRAWICON(TJ,HIGH*1.01+0.02,2);
警告灯:IF(TJ,HIGH*1.008,DRAWNULL),CROSSDOT,LINETHICK2,COLORCYAN;
PL:=BARSLAST(TJ);
支撑:IF(BARSLAST(TJ1),
REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORGRAY,LINETHICK2;
TJ_2:=LOW>REF(REF(LOW,TS),PL);
DRAWTEXT(ISLASTBAR,压力,'压力'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLOREA91B5;
{DRAWICON(COUNT(TJ_2,PL+1)=1,HIGH*1.005,2);{//向下的箭头表示出局点}
{DRAWICON(BARSLAST(TJ1),REF(LOW*0.995,BARSLAST(TJ1)),1);};
A11:=(CLOSE+HIGH+LOW)/3;
A21:=EMA(A11,3);
A311:=REF(A21,1);
A41:=IF(A21>A311,A21,DRAWNULL);
A51:=IF(A21<=A311,A21,DRAWNULL);
STICKLINE(CROSS(C,REF(A51,1)),REF(A51,1)*1.002,REF(A51,1),20,0),COLORRED;
DRAWTEXT(CROSS(REF(A4,1),C) AND A4,H,'↓开跌'),COLORGREEN;
{www.gupang.com 股旁网_通达信指标公式}
LC:=REF((O+H+L+2*C)/5,1);
RSI:=SMA(MAX(C-LC,0),7,1)/SMA(ABS(C-LC),7,1)*10;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,23))/(0.015*AVEDEV(TYP,23));
买11:=CROSS(RSI,7.1) AND MA(V,5)>MA(V,10),COLORRED;
DRAWTEXT(CROSS(RSI,7.1) AND MA(V,5)>MA(V,10),L,'◆◆黑马◆◆'),COLORWHITE;
DRAWICON(买,(LOW * 0.98),17);
卖:=CROSS(7.1,RSI) AND MA(V,10)>MA(V,5),COLORGREEN;
DRAWTEXT(CROSS(7.1,RSI) AND MA(V,10)>MA(V,5),H*1.04,'■■■逃跑■■■'),COLORGREEN;
DRAWICON(卖,(H*1.03),28);
A110:=(REF(EMA(CLOSE,5),1));
B1:=CROSS(EMA(CLOSE,5),EMA(SLOPE(CLOSE,21)*20+CLOSE,42));
DRAWTEXT(B1,LOW*0.995,'追'),COLORFFFF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DRAWTEXT(CROSS(J,D),LOW*0.98,'加'),COLOR00FFFF,LINETHICK2;
VAR29:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR2A:=SMA(VAR29,5,1);
VAR2B:=SMA(VAR2A,10,1);
VAR2C:=CROSS(VAR2B,VAR2A);
VAR2D:=VAR2B>80 OR VAR2A>80;
VAR2E:=VAR2C AND VAR2D;
VAR33:=HIGH;
VAR34:=LOW;
逃顶:=STICKLINE(VAR2E,VAR33,VAR34,4,0);
DRAWTEXT(CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),HIGH*1.01,'抛'),COLORGREEN;
X6:=REF(CLOSE,1);
X7:=SMA(MAX(CLOSE-X6,0),7,1)/SMA(ABS(CLOSE-X6),7,1)*100;
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);DRAWTEXT(X9,HIGH*1.03,'出货'),COLOR9000F5;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,3.15,0),COLOR337777;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,2.45,0),COLOR339999;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.75,0),COLOR33BBBB;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.05,0),COLOR33DDDD;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,0.35,0),COLOR33FFFF;
DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L*0.99,'地量买点'),COLOR33FFFF;
DRAWTEXT(CROSS(88,RSI),(HIGH*1.01),'R背'),COLOR00FF00;
VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5);
VAR5S:=HHV(HIGH,4);
AA17:=EMA(C,14)COLORWHITE,LINETHICK1;
A17X:=(AA17-REF(AA17,1))/REF(AA17,1)*100,NODRAW;
参考线试买:IF(A17X>=0,REF(EMA(C,14),BARSLAST(CROSS(A17X,0))+1),DRAWNULL)COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,参考线试买,'参考线试买'),COLORYELLOW,LINETHICK4;

通达信网牛线主图指标公式

 

相关文章