在线检测未来函数

通达信庄家任你涨跌指标公式

来源:Internet,编辑:股旁网,2013-02-03

GLL:=-6;
VARY13:=HHV(HIGH,21);
VARY14:=LLV(LOW,21);
D:= EMA((CLOSE-VARY14)/(VARY13-VARY14)*100,5), COLORRED, LINETHICK2;
K:= EMA((CLOSE-VARY14)/(VARY13-VARY14)*100,20), , LINETHICK2 COLORFF9933;
底:= 5, ,POINTDOT LINETHICK1 COLORGREEN;
IF(CROSS(K,D) AND D>55,100,115),COLORCYAN,LINETHICK2;
JM:=IF(YEAR>=2006 AND MONTH>12,0,1);
VAR1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=LLV(LOW,5);
VAR6:=HHV(HIGH,5);
VAR7:=EMA((CLOSE-VAR5)/(VAR6-VAR5)*100,4)*2;
VAR8:=EMA(0.667*REF(VAR7,1)+0.333*VAR7,2);
VAR9:=3*VAR7-2*VAR8;
VARA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARB:=POW(MA(LOW,5),2)+MA(LOW,5);
VARC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
{www.gupang.com 股旁网_通达信股票指标公式}
VARD:=(VARA-LLV(VARB,64))/(HHV(VARC,64)-LLV(VARB,64))*150+65-10;
VARE:=SMA(VARD,3,1)*1.5-100;
VARF:=SMA(VARE,3,1);
VAR10:=3*VARE-2*VARF;
VAR11:=(HIGH+LOW+CLOSE*2)/4;
VAR12:=EMA(VAR11,13);
VAR13:=STD(VAR11,13);
VAR14:=(VAR11-VAR12)*100/VAR13;
VAR15:=EMA(VAR14,5);
VAR16:=EMA(VAR15,13);
VAR17:=EMA(VAR15,13)+200-100;
VAR18:=EMA(VAR17,10);
VAR19:=3*VAR17-2*VAR18;
VAR1A:=VAR2+VAR7+VARE+VAR17;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=(HIGH+LOW+CLOSE)/3;
VAR1E:=AMOUNT/VOL/100;
VAR1F:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR20:=(VAR1D-MA(VAR1D,34))/(0.015*AVEDEV(VAR1D,34));
VAR22:=(HIGH+LOW+CLOSE+VAR1D)/4;
VAR23:=EMA(VAR22,24);
VAR24:=STD(VAR22,24);
VAR25:=(VAR22-VAR23)/VAR24*100;
VAR26:=(VAR1D-MA(VAR1D,24))/(0.015*AVEDEV(VAR1D,24));
VAR27:=EMA(VAR25,5);
VAR28:=(VAR1E-MA(VAR1E,21))/(0.015*AVEDEV(VAR1E,21));
VAR29:=(VAR1F-MA(VAR1F,90))/(0.015*AVEDEV(VAR1F,90));
VAR2A:=(({VAR29+VAR28+}VAR27+VAR26+VAR20)/3+165)/4;
VAR2B:=(EMA(EMA(EMA(VAR2A,15),10),5)-25)*2;
VAR2C:=(VAR1A+VAR1B+VAR1C*30)/32/5-15;
VAR2D:=EMA(VAR2C,13);
VAR2E:=(VAR2A+VAR2C)/2/1.1;
DXM:= VAR2E*JM ,COLORGREEN,LINETHICK1;
DX1:EMA(DXM,1),COLORFF3366,LINETHICK2;
DX2:=EMA(DX1,12),COLOR889900,LINETHICK2;
ZX:EMA((VAR2B+VAR2D)/2,2) , COLORDDDDDD,LINETHICK2;
STICKLINE(ZX-REF(ZX,1)>0 ,ZX,0,10,0),COLORWHITE,LINETHICK1,POINTDOT;
STICKLINE(ZX-REF(ZX,1)<0 ,ZX,0,10,0),COLORFF9999,POINTDOT;
红灯:STICKLINE(ZX>100 ,120,110,10,0), COLORRED;
BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3),COLORCC0033,LINETHICK1;
J:=CROSS(DX1,0) AND COUNT(MN<-12,2)>=1 OR CROSS(DX1,ZX) AND COUNT(MN<-12,2)>=1;
DRAWICON(J,100,1);
DRAWICON(CROSS(DX1,ZX) AND COUNT(MN<GLL,2)>=1 OR (CROSS(DX1,0) AND COUNT(MN<GLL,1)>=1)
OR (CROSS(DX1,DX2) AND COUNT(MN<GLL,1)>=1)},-5,3);
DIFF:=( EMA(CLOSE,12) - EMA(CLOSE,26))*10;DEA:=EMA(DIFF,12);
STICKLINE(( (CROSS(100,DX1) OR CROSS(ZX,DX1) AND ZX>80) )>0,0,ZX,3,0)COLORGREEN;
预警:90,COLORRED,LINETHICK1;
安全区:10,COLORYELLOW;

通达信庄家任你涨跌指标公式

 

相关文章