在线检测未来函数

通达信神彩飞扬主图指标公式

来源:Internet,编辑:股旁网,2013-02-07

A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
HJX21:=(21*A+20*REF(A,1)+19*REF(A,2)+18*REF(A,3)+17*REF(A,4)+16*REF(A,5)+
15*REF(A,6)+14*REF(A,7)+13*REF(A,8)+12*REF(A,9)+11*REF(A,10)+
10*REF(A,11)+9*REF(A,12)+8*REF(A,13)+7*REF(A,14)+6*REF(A,15)+
5*REF(A,16)+4*REF(A,17)+3*REF(A,18)+2*REF(A,19)+
REF(A,21))/231;
HJX3:=(3*A+2*REF(A,1)+REF(A,2))/6;
DC1:EMA(HJX3,4),COLORLIMAGENTA;
DC2:EMA(DC1,3),COLORRED;
DC3:EMA(DC1,7),COLORRED;
K1:=BACKSET(DC1<REF(DC1,1),2);
IF(K1,DC1,DRAWNULL),COLORGREEN,LINETHICK1;
K2:=BACKSET(DC2<REF(DC2,1),2);
IF(K2,DC2,DRAWNULL),COLORGREEN,LINETHICK1;
K3:=BACKSET(DC3<REF(DC3,1),2);
IF(K3,DC3,DRAWNULL),COLORGREEN,LINETHICK1;
DC4:EMA(HJX21,6),COLORYELLOW;
DC5:EMA(HJX21,16),COLORYELLOW;
DC6:EMA(HJX21,34),COLORYELLOW;
RSV:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
YX2:=D>REF(D,1);
YX3:=DC4>DC6 AND DC5>DC6;
YX4:=CLOSE>DC4 AND CLOSE/DC4<1.1;
YX5:=DC1>DC2 AND DC2>DC3;
XG:=YX2 AND YX3 AND YX4;
神彩飞扬培训:=XG AND COUNT(XG,10)=1 AND COUNT(YX5,10)<5;
DRAWTEXT(神彩飞扬培训,LOW*0.98,'神彩'),COLORFFFFFF;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
XG0:=CROSS(MACD,0);
XG1:=CROSS(CLOSE,DC1) AND CROSS(CLOSE,DC2) AND CROSS(CLOSE,DC3) AND BARSLAST(XG0)<=5
AND CLOSE<DC4 ;
DRAWTEXT(XG1,LOW*0.98,'叠彩'),COLORFF00FF;
HJX:=EMA(HJX21,12);
ZF:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
TTUP:=HJX+2*STD(CLOSE,20);
TTDOWN:=HJX-2*STD(CLOSE,20);
HUP:=EMA(TTUP,3);
HDOWN:=EMA(TTDOWN,3);
LBRISE:=HUP/REF(HUP,1)>1.0035;
MIDRISE:=HJX>REF(HJX,1);
LBDOWN:=HDOWN<REF(HDOWN,1);
CLB1:=LOW/HUP<1.01 AND CLOSE/HUP>0.99 AND (OPEN+LOW)/2.1<HUP ;
KXT:=CLOSE>OPEN AND ((HIGH-CLOSE)+(OPEN-LOW))/(CLOSE-OPEN)<1.2 AND HIGH/CLOSE<1.035;
TDKD:=100*(HUP-HDOWN)/HJX;
TDXT:=TDKD<15 AND LLV(TDKD,8)<10;
{www.gupang.com 股旁网-通达信指标公式}
XGG:=LBRISE AND MIDRISE AND CLB1 AND KXT AND TDXT;
CXG:=COUNT(XGG,20);
喇叭开口:=XGG AND CXG=1 AND COUNT(LBRISE,10)<10 AND HIGH/HHV(HIGH,5)>0.98;
DRAWTEXT(喇叭开口,LOW*0.99,'喇叭'),COLORFFFF00;
DRAWICON(CROSS(DC1,DC2),LOW*0.99,5);
DRAWICON(神彩飞扬培训,LOW*0.970,9);
DRAWICON(喇叭开口,LOW,2),COLORFFFF00;

通达信神彩飞扬主图指标公式

 

相关文章