在线检测未来函数

通达信股似恋情主图指标公式

来源:Internet,编辑:股旁网,2013-02-07

气质品味:=(+H+L+C+O)/4;
贞操线:MA(气质品味,5),COLORGREEN;
认命线:MA(气质品味,10),COLORYELLOW;
妇道线:MA(气质品味,20),COLORMAGENTA,LINETHICK2;
Y:=(气质品味-妇道线)/气质品味*100;
{破顶而出}
YY1:=C>气质品味 AND OPEN<气质品味;
YY3:=C>认命线 AND OPEN<认命线;
YY5:=C>妇道线 AND OPEN<妇道线;
DRAWTEXT(YY1 AND YY5 AND YY3,LOW-0.1,'1进酒吧'),COLORRED;
{志同道合}
SJ1:=ABS(气质品味-MA(CLOSE,33))<C*0.01;
SJ2:=ABS(MA(CLOSE,33)-MA(CLOSE,55))<C*0.01;
SJ3:=CROSS(气质品味,MA(CLOSE,55));
DRAWTEXT(SJ1 AND SJ2 AND SJ3,HIGH+0.1,'2观望'),COLORRED;
{郎才女貌}
RY1:=C/OPEN>1.04;{阳线4%}
RY2:=REF(OPEN,1)/REF(CLOSE,1)>1.04;{阴线4%}
RY3:=ABS(OPEN-REF(C,1))<C*0.02 AND ABS(C-REF(OPEN,1))<C*0.02;
DRAWTEXT(RY1 AND RY2 AND RY3 ,LOW,'3搭讪'),COLORYELLOW;
{润之初}
JG1:=ABS(气质品味-认命线)<C*0.02 AND ABS(气质品味-妇道线)<C*0.02;
JG2:=O>气质品味 OR O=气质品味;
JG3:=C/OPEN>1.03 ; {阳线3%}
JG:=JG1 AND JG2 AND JG3;
DRAWTEXT(JG,LOW-0.2,'4有好感'),COLORYELLOW;
{感情笃深}
HY1:=CROSS(气质品味,妇道线);{11线上穿55线}
HY2:=OPEN<C AND C/OPEN>1.02; {阳线3%}
HY3:=ABS(OPEN-气质品味)<C*0.05;{开盘在11线附近}
HY:=HY1 AND HY2 AND HY3;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT(HY,LOW,'5拥抱'),COLORRED;
{互顶终身}
JW1:=C<OPEN AND REF(C,1)<REF(OPEN,1);
JW2:=OPEN<REF(C,1) AND C>REF(L,1);
JW3:=O<气质品味 AND O<认命线 AND O<妇道线;
JW:=JW1 AND JW2 AND JW3;
DRAWTEXT(JW,LOW-0.2,'6上床'),COLORYELLOW;
{借酒献意}
TS1:=CROSS(气质品味,认命线);{11线上穿33线}
TS2:=气质品味<妇道线;
TS:=TS1 AND TS2;
DRAWTEXT(TS,LOW-0.2,'*借酒献意'),COLORF00FF0;
{*爱之决}
MK1:=气质品味>妇道线 AND 认命线>妇道线;
MK:=TS1 AND MK1;
DRAWTEXT(MK,H+0.4,'*爱之决'),COLORGREEN;
{*欲仙欲死}
YZ1:=C/O>1.02 AND H/C>1.02 AND O/L<1.02;{收阳有上影}
YZ2:=REF(C,1)>REF(O,1) AND O>气质品味;{昨收阳 今大于均线}
YZ:=YZ1 AND YZ2 AND Y>10;
DRAWTEXT(YZ,HIGH+0.2,'*欲仙欲死'),COLORF00FF0;
{激情顶点}
DS1:=OPEN/C>1.04 AND O/REF(C,1)>1.03;{高开收阴}
DS2:=V*100/FINANCE(7)>0.08 AND Y>8;{换手高涨幅大}
DS:=DS1 AND DS2;
DRAWTEXT(DS,HIGH+0.2,'7结束恋情'),COLORGREEN;
{一日夫妻百日恩}
YJ1:=H/O>1.04;
YJ2:=ABS(C-O)<C*0.03;
YJ3:=C/气质品味>1.1;
YJ:=YJ1 AND YJ2 AND DS2 AND YJ3 AND YZ2;
DRAWTEXT(YJ,HIGH+0.3,'8分手'),COLORRED;
{*打情骂俏}
HK1:=CROSS(气质品味,妇道线);{11线上穿55线}
HK2:=C<O;{当日收阴}
HK3:=ABS(L-气质品味)<C*0.03 OR ABS(C-贞操线)<C*0.04;{收盘价或最低价在11线}
HK:=HK1 AND HK2 AND HK3;
DRAWTEXT(HK,LOW,'*打情骂俏'),COLORGREEN;
{涨停做记号}
CM:=REF(C,1);
涨停:=IF((C-CM)*100/CM>=9.9,1,0);
STICKLINE(涨停,OPEN,CLOSE,3.8,0),COLORMAGENTA;
STICKLINE(涨停,H,L,0,0),COLORLIRED;
跌停:=IF((C-CM)*100/CM<=-9.9,1,0);
STICKLINE(跌停,OPEN,CLOSE,3.8,0),COLORGREEN;
STICKLINE(跌停,H,L,0,0),COLORGREEN;

通达信股似恋情主图指标公式

 

相关文章