在线检测未来函数

通达信涨停先兆主图指标公式

来源:Internet,编辑:股旁网,2013-02-19

DRAWTEXT_FIX(1,0.00,1,0,'所属行业:')COLOR0080FF;
DRAWTEXT_FIX(1,0.08,1,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.14,1,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.22,1,0,DYBLOCK)COLOR00FFFF;
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20)LINETHICK2;
MA4:MA(CLOSE,60);
MA5:MA(CLOSE,120);
MA6:MA(CLOSE,238);
DRAWTEXT(CROSS(MA4,MA5),MA5*0.985,'牛度')COLORLIGRAY;
涨停:=(CLOSE/REF(CLOSE,1)-1)*100>10-3.);
STICKLINE(涨停,O,C,3,0),COLOR009999;
STICKLINE(涨停,O,C,2,0),COLOR00DDDD;
STICKLINE(涨停,O,C,1,0),COLOR00FFFF;
STICKLINE(涨停,O,C,0.5,0),COLORYELLOW;
STICKLINE(涨停,O,C,0.2,0),COLORYELLOW;
N:=10;
T1:=CONST(HHVBARS(V,N));
M:=10;
Q1:=CONST(REF(HHVBARS(V,M),T1+1)+T1+1);
Q0:IF(CURRBARSCOUNT<=T1+M+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,Q1)),DRAWNULL),COLOR009900;
IF(CURRBARSCOUNT=Q1+1,Q0,DRAWNULL)LINETHICK5,CIRCLEDOT,COLOR00CC00;
M1:=CONST(LLVBARS(V,M));
M0:IF(CURRBARSCOUNT<=M+7,CONST(IF(M1=0,O,REF(O,M1))),DRAWNULL)LINETHICK2,COLORMAGENTA;
IF(CURRBARSCOUNT=M1+1,M0,DRAWNULL)LINETHICK3,COLORYELLOW,CIRCLEDOT;
DRAWTEXT(ISLASTBAR,M0,' 纵轴1位置')COLORLIMAGENTA;
DRAWTEXT(ISLASTBAR,MA2,'关注均线角度');
{画线主图 TDX N:1,100,8}
ZGD:=HHV(H,50);
ZGD2:=CONST(ZGD)*1.08;
ZDD:=LLV(L,50);
ZDD2:=CONST(ZDD)*0.9;
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
今日阻力:=REF(明日阻力,1),NODRAW;
今日支撑:=REF(明日支撑,1),NODRAW;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDDDD:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
压力位:IF(ISLASTBAR,压力2,DRAWNULL),NODRAW;
底部:=LLV(HIGH,30),COLOR00FF00;
底部位:IF(ISLASTBAR,底部,DRAWNULL),NODRAW;
AA:=REF(H,8)=HHV(H,2*8+1);
QY:=BACKSET(AA,8+1);
CC:=FILTER(QY,8) AND H=HHV(H,8+1);
DDD:=BARSLAST(CC),NODRAW;
GDTS:=IF(CC,CURRBARSCOUNT,0),NODRAW;
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS),NODRAW;
GDCS1:=CONST(DINGBUTS),NODRAW;
GDCS13:=CONST(REF(HIGH,GDCS1-1));
DINGBUTS1:=REF(DINGBUTS,DDD+1),NODRAW;
GDCS2:=CONST(DINGBUTS1);
GDCS23:=CONST(REF(HIGH,DINGBUTS1-1));
XG1:=BACKSET(ISLASTBAR,GDCS1);
XG2:=BACKSET(ISLASTBAR,DINGBUTS1);
高点压力:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) ,COLORBLUE,LINETHICK1;
AA1:=REF(L,8)=LLV(L,2*8+1);
QY1:=BACKSET(AA1,8+1);
CC1:=FILTER(QY1,8) AND L=LLV(L,8+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
DDCS13:=CONST(REF(L,DDCS1-1));
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
DDCS23:=CONST(REF(L,DDTS2-1));
XD1:=BACKSET(ISLASTBAR,DDCS1);
XD2:=BACKSET(ISLASTBAR,DDTS2);
低点支撑:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1),COLORBLUE,LINETHICK1;
{DRAWBAND(高点压力,RGB(00,00,100),低点支撑,RGB(00,00,00));}
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:=DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLOR555555,LINETHICK1;
MM:=INTPART(3*8/5);
AAA:=REF(H,MM)=HHV(H,2*MM+1);
QYY:=BACKSET(AAA,MM+1);
{www.gupang.com 股旁网_通达信股票指标公式}
CCC:=FILTER(QYY,MM) AND H=HHV(H,MM+1);
DDDD:=BARSLAST(CCC),NODRAW;
GDTSS:=IF(CCC,CURRBARSCOUNT,0),NODRAW;
DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS),NODRAW;
GDCS11:=CONST(DINGBUTSS),NODRAW;
DINGBUTS11:=REF(DINGBUTSS,DDDD+1),NODRAW;
GDCS22:=CONST(DINGBUTS11);
高点压力M:=DRAWLINE(CURRBARSCOUNT=GDCS22,H,CURRBARSCOUNT=GDCS11,H,1),COLORRED,LINETHICK1;
AA11:=REF(L,M)=LLV(L,2*M+1);
QY11:=BACKSET(AA11,M+1);
CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);
DD11:=BARSLAST(CC11);
DDTSS:=IF(CC11,CURRBARSCOUNT,0);
DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);
DDCS11:=CONST(DDTS11);
DDTS22:=REF(DDTS11,DD11+1);
DDCS22:=CONST(DDTS22);
低点支撑M:=DRAWLINE(CURRBARSCOUNT=DDCS22,L,CURRBARSCOUNT=DDCS11,L,1) COLORRED,LINETHICK1;
STICKLINE(XG2,GDCS23,GDCS23,3,1),COLORWHITE,LINETHICK3;
STICKLINE(XG1,GDCS13,GDCS13,3,1),COLORYELLOW,LINETHICK3;
STICKLINE(XD2,DDCS23,DDCS23,3,1),COLORMAGENTA,LINETHICK3;
STICKLINE(XD1,DDCS13,DDCS13,3,1),COLORCYAN,LINETHICK3;

通达信涨停先兆主图指标公式

 

相关文章