在线检测未来函数

通达信阿贵量图指标公式

来源:Internet,编辑:股旁网,2013-02-23

大单比率:(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7),NODRAW;
主力增减仓%:LARGEINTRDVOL/LARGEOUTTRDVOL,NODRAW;
RV5:=IF(BARSCOUNT(CLOSE)<6,REF(SUM(VOL,BARSCOUNT(CLOSE))/BARSCOUNT(CLOSE),1),REF(MA(VOL,5),1));
V1:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT AND BARSCOUNT(CLOSE)>1,DYNAINFO(17)*RV5,VOL),VOLSTICK;
STICKLINE(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT AND BARSCOUNT(CLOSE)>1,O,V1,3,-1),COLOR336699;
虚量:V1;
实量:VOL,VOLSTICK;
虚换手:V1/FINANCE(7)*10000;
十日换:SUM(V/CAPITAL*100,3),COLORLICYAN,NODRAW;
量比:V/REF(MA(V,5),1)COLORYELLOW;
百日总:=SUM(V,100);
百日换:百日总/CAPITAL*100,LINETHICK0;
持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORFF00FF,LINETHICK2,NODRAW;
LC:=REF(CLOSE,1);
RSI5:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活跃度:(RSI5-WR10),COLORFFFF00,LINETHICK1,NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),虚量,0,-1,-1),COLOR00C0C0;
STICKLINE("MACD.MACD">0,0,V,2.8,1),COLORRED;
STICKLINE("MACD.MACD"<=0,0,V,2.8,1),COLORCYAN;
倍量:=(V>REF(V,1)*2 OR 虚量>REF(V,1)*2) AND C>REF(C,1);
STICKLINE(倍量,V,0,2,0),COLORYELLOW;
倍缩量:=(V<HHV(REF(V,1),5)/2 OR 虚量<HHV(REF(V,1),5)/2) AND C<REF(C,1);
STICKLINE(倍缩量,V,0,2,0),COLORRED;
STICKLINE((V>REF(V,1) AND REF(倍量,1)=1) AND C>REF(C,1),0,V,2,0),COLORYELLOW;
STICKLINE((V>REF(V,1) AND REF(V,1)>REF(V,2) AND REF(倍量,2)=1) AND C>REF(C,1),0,V,2,0),COLORYELLOW;
STICKLINE((V>REF(V,1) AND REF(V,1)>REF(V,2) AND REF(V,2)>REF(V,3) AND REF(倍量,3)=1) AND C>REF(C,1),0,V,2,0),COLORYELLOW;
STICKLINE((V>REF(V,1) AND REF(V,1)>REF(V,2) AND REF(V,2)>REF(V,3) AND REF(V,3)>REF(V,4) AND REF(倍量,4)=1) AND C>REF(C,1),0,V,2,0),COLORYELLOW;
STICKLINE((V>REF(V,1) AND REF(V,1)>REF(V,2) AND REF(V,2)>REF(V,3) AND REF(V,3)>REF(V,4) AND REF(V,4)>REF(V,5) AND REF(倍量,5)=1) AND C>REF(C,1),0,V,2,0),COLORYELLOW;
收阳线:=(C>REF(C,1));
地量1:=VOL<LLV(VOL,60)*1.001;
地量:=地量1 AND 收阳线;
地量反弹:=收阳线 AND VOL>REF(VOL,1)*1.05 AND REF(地量,1);
STICKLINE(地量反弹>0,0,VOL,2,0),COLORYELLOW;
STICKLINE(地量>0,0,VOL,2,0),COLORMAGENTA;
DRAWICON(收阳线 AND VOL>REF(VOL,1)*1.05 AND REF(地量,1),实量+8000,5),COLORMAGENTA;
{--------VOL.量能饱和--------}
N1:=34;
N2:=N1*1.05;
N3:=N1+3;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:IF(SAT>1,1,SAT)*100,COLOR0099FF,NODRAW;
中点:=REF(REFDATE(HHV(V,60)/2,DATE),5);{量能饱和的变色切换}
{中点:=REFDATE(HHV(V,240)/2,DATE);}
{--------VOL.量能饱和--------}
STICKLINE(CURRBARSCOUNT=N1,中点*1.8,中点*1.6,100,1),COLOR00DDDD;
STICKLINE(CURRBARSCOUNT=N1,中点*1.79,中点*1.61,量能饱和度,0),COLOR0055FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.76,中点*1.64,量能饱和度,0),COLOR0077FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.73,中点*1.67,量能饱和度,0),COLOR0099FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.7,中点*1.7,量能饱和度,0),COLOR00DDFF;
DRAWTEXT(CURRBARSCOUNT=N3,中点*1.7,'量能饱和度'),COLORYELLOW;
五日:MA(VOL,5) COLORGREEN LINETHICK2;
十日:MA(VOL,10) COLORYELLOW LINETHICK2;
六十日:MA(VOL,60) COLORMAGENTA LINETHICK2;
IF(五日>六十日,五日,DRAWNULL),LINETHICK2,COLORRED;
主力净买:(LARGEINTRDVOL-LARGEOUTTRDVOL)*DYNAINFO(11),NODRAW;
主力买入:(LARGEINTRDVOL)*DYNAINFO(11)/100,NODRAW;
主力卖出:(LARGEOUTTRDVOL)*DYNAINFO(11)/100,NODRAW;
STICKLINE(主力净买>0,主力净买,主力净买,0.5,0),COLOR0000FF;
STICKLINE(主力净买<0,主力净买,主力净买,0.5,0),COLOR00FF00;
STICKLINE(主力净买>0,主力净买,0,0.5,0),COLOR00006F;
STICKLINE(主力净买<0,主力净买,0,0.5,0),COLOR006F00;
STICKLINE(主力净买>0,主力净买/8*7,0,0.5,0),COLOR00009F;
STICKLINE(主力净买<0,主力净买/8*7,0,0.5,0),COLOR009F00;
STICKLINE(主力净买>0,主力净买/4*3,0,0.5,0),COLOR0000CF;
STICKLINE(主力净买<0,主力净买/4*3,0,0.5,0),COLOR00CF00;
STICKLINE(主力净买>0,主力净买/2,0,0.5,0),COLOR0000FF;
STICKLINE(主力净买<0,主力净买/2,0,0.5,0),COLOR00FF00;
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S);
超大单:=(超B)-(超S);
大单:=(大B)-(大S);
中单:=(中B)-(中S);
小单:=(小B)-(小S);
DAZHI:=CONST(MAX(ABS(净流入),MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单)))))),NODRAW;
DRAWRECTREL(0,0,282,999.2,IF(120,RGB(10,0,0),0));
DRAWRECTREL(0,CONST(880-(ABS(净流入)*500/DAZHI)),50,880,IF(CONST(净流入)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(58,CONST(880-(ABS(超大单)*500/DAZHI)),108,880,IF(CONST(超大单)>0,RGB(102,0,204),RGB(23,125,255)));
DRAWRECTREL(116,CONST(880-(ABS(大单)*500/DAZHI)),166,880,IF(CONST(大单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(174,CONST(880-(ABS(中单)*500/DAZHI)),224,880,IF(CONST(中单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(232,CONST(880-(ABS(小单)*500/DAZHI)),282,880,IF(CONST(小单)>0,RGB(255,0,0),RGB(0,128,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.002,1,0,'净流入'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.060,1,0,'超大单'),COLOR660099;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.126,1,0,'大单'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.181,1,0,'中单'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.241,1,0,'小单'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0,0.001,0,'单位(万元)'),COLORYELLOW;
{M:=0.53;M1:=0.33;}M:=0.58;M1:=0.39;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.001,0.790,0,CEILING(净流入));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.059,0.790,0,CEILING(超大单));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.116,0.790,0,CEILING(大单));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.175,0.790,0,CEILING(中单));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.232,0.790,0,CEILING(小单));
STICKLINE(C/REF(C,1)>=1.099,0,VOL,1,0),COLORMAGENTA;
STICKLINE(REF(C,1)/C>=1.099 AND C<O AND C<REF(C,1),0,VOL,1,0),COLORBLUE;
DRAWTEXT_FIX(ISLASTBAR,0,0.05,0,'粉心涨停 蓝心跌停 红心绿心是大单 '),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0,0.15,0,'黄柱倍量 红柱倍缩 笑脸前面是地量'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0,0.25,0,'红边可操作 篮边要休息 '),COLORMAGENTA;

通达信阿贵量图指标公式

 

相关文章