在线检测未来函数

通达信三色筹码指标公式

来源:Internet,编辑:股旁网,2013-02-25

VAR1:=1;
VAR2:=BARSCOUNT(CLOSE)*VAR1;
VAR3:=IF(VAR2>5,5,VAR2)*VAR1;
VAR4:=IF(VAR2>10,10,VAR2)*VAR1;
VAR5:=IF(VAR2>20,20,VAR2)*VAR1;
VAR6:=IF(VAR2>120,120,VAR2)*VAR1;
VAR7:=SUM(AMOUNT,VAR3)*VAR1;
VAR8:=SUM(AMOUNT,VAR4)*VAR1;
VAR9:=SUM(AMOUNT,VAR5)*VAR1;
VARA:=SUM(AMOUNT,VAR6)*VAR1;
VARB:=100*VAR9/VARA*VAR1;
VARC:=100*VAR8/VARA*VAR1;
VARD:=100*VAR7/VARA*VAR1;
VARE:=SUM(VARB,2)/2*VAR1;
VARF:=SUM(VARC,2)/2*VAR1;
VAR10:=SUM(VARD,10)/10*VAR1;
VAR11:=SUM(VARE,2)/2*VAR1;
VAR12:=SUM(VARF,2)/2*VAR1;
VAR13:=SUM(VAR10,2)/2*VAR1;
长线资金: STICKLINE(VARE>VARF AND VARF>VAR10 AND VARE>VAR10 AND VARE>REF(VARE,1) AND VARF>REF(VARF,1) AND VAR10>REF(VAR10,1),VARB,VARC,5,0)*VAR1, , COLORRED;
中线资金: STICKLINE(VARE>VARF AND VARF>VAR10 AND VARE>VAR10 AND VARE>REF(VARE,1) AND VARF>REF(VARF,1) AND VAR10>REF(VAR10,1),VARC,VARD,5,0)*VAR1, , COLORYELLOW;
短线资金: STICKLINE(VARE>VARF AND VARF>VAR10 AND VARE>VAR10 AND VARE>REF(VARE,1) AND VARF>REF(VARF,1) AND VAR10>REF(VAR10,1),VARD,0,5,0)*VAR1, ,COLORBLUE;
资金离场: IF(VARE>VARF AND VARF>VAR10 AND VARE>VAR10 AND VARE>REF(VARE,1) AND VARF>REF(VARF,1) AND VAR10>REF(VAR10,1),0,VARB)*VAR1,STICK;

通达信三色筹码指标公式

 

相关文章