在线检测未来函数

通达信春夏秋冬指标公式

来源:Internet,编辑:股旁网,2013-03-02

主线:=EMA(EMA(C,1),5);
本:=EMA(HHV(主线,5),1),COLOR00FFFF,LINETHICK2;
急:=EMA(HHV(本,21),1),COLOR0089FF,LINETHICK1;
稳:=EMA(HHV(急,21),2),COLORDB89FF,COLOR00FF00,LINETHICK2;
投:=EMA(HHV(稳,21),3),COLOR8916FF,LINETHICK1;
散:=EMA(HHV(投,21),4),COLORFFCC62,LINETHICK1;
集:=EMA(HHV(散,21),5),COLORFFFFFF,LINETHICK2;
马:=EMA(HHV(集,21),6),COLORFF5B5E,LINETHICK2;
OX:0;
XG:=主线/马*100-100;
春:=XG<0 AND XG>=REF(XG,1);
夏:=XG>0 AND XG>REF(XG,1);
秋:=XG>0 AND XG<REF(XG,1);
冬:=XG<0 AND XG<REF(XG,1);
春天1:=IF(春=1,XG,MA(XG,10)),COLORMAGENTA,LINETHICK2;
夏天1:=IF(夏=1,XG,MA(XG,10)),COLORRED,LINETHICK2;
秋天1:=IF(秋=1,XG,MA(XG,10)),COLORYELLOW,DOTLINE;
冬天1:=IF(冬=1,XG,MA(XG,10)),COLORCYAN,DOTLINE;
STICKLINE(春天1>MA(XG,10),春天1,MA(XG,10),2,0),COLORFF00FF;
STICKLINE(夏天1>MA(XG,10),夏天1,MA(XG,10),2,0),COLORRED;
STICKLINE(秋天1<MA(XG,10),秋天1,MA(XG,10),2,0),COLORBROWN;
STICKLINE(冬天1<MA(XG,10),冬天1,MA(XG,10),2,0),COLORCYAN;
春天:IF(春=1,C,MA(XG,10)),COLORMAGENTA,LINETHICK1;
夏天:IF(夏=1,C,MA(XG,10)),COLORRED,LINETHICK1;
秋天:IF(秋=1,-1,MA(XG,10)),COLORYELLOW,DOTLINE;
冬天:IF(冬=1,-20,MA(XG,10)),COLORCYAN,DOTLINE;

通达信春夏秋冬指标公式

 

相关文章