在线检测未来函数

大智慧底部将成指标公式

来源:Internet,编辑:股旁网,2013-03-05

Var1:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
Var2:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
Var3:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
Var4:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;
Var5:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
Var6:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
Var7:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
Var8:=(Var2+Var3+Var4+Var5+Var6+Var7)/6;
Var9:=EMA(Var8,3);
VarA:=ABS(Var5-Var7);
VarB:=(Var8+VarA)/2;
VarC:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
VarD:=VarC+VarB;
VarE:=IF(Var1>0 AND VarD<0,200,0);
VarF:=IF(VarB<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
Var10:=IF(VarD<0 AND VarF=-50,100,0);
Var11:=MA(CLOSE,3);
Var12:=REF(CLOSE,2)*0.865;
Var13:=REF(CLOSE,13)*0.772;
Var14:=MIN(Var12,Var13);
Var15:=100*VOL/CAPITAL;
Var16:=MA(CLOSE,13);
Var17:=IF((CLOSE-Var14)/CLOSE<0.03 AND SUM(Var15,5)/5<1.8,1,0);
Var18:=IF(Var17>0 AND (VarF<0 OR Var1>0),100,0);
Var19:=Var18;
Var1A:=IF(VarE>0 AND Var10>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var17>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (VarE>0 AND Var10>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var17>0) AND (VarF<0 OR Var1>0) AND Var18<10,50,0);
Var1B:=(VarE>0 AND Var10>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var17>0) AND (VarF<0 OR Var1>0);
Var1C:=VarE>0 AND Var10>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var17>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
Var1D:=Var1B OR Var1C;
Var1E:=Var19 OR Var1D;
Var1F:=Var18;
Var20:=MA(CLOSE,80)-MA(CLOSE,10)/3;
买1: IF(Var1E>0,87,0),colorred;
买2: IF(Var1F>0,91,0),colorgreen;
买3: IF(Var18>0 AND CLOSE<Var20,97,0),coloryellow;
满仓: MAX(MAX(买3,买1),买2), colorstick;
Var21:=MA(CLOSE,80)-MA(CLOSE,13)/3;
Var22:=MA((CLOSE-Var21)/Var21,1);
Var23:=IF(CROSS(Var22,0) AND LOW/REF(HIGH,1)<1.012,0.5,0);
Var24:=IF(COUNT(Var22>REF(Var22,1),3)=3 AND COUNT(Var22<0,10)=10 AND REF(Var22,3)=LLV(Var22,10),0.5,0);
Var25:=IF(REF(Var22,2)=LLV(Var22,20) AND REF(Var22,2)<0.071 AND REF(Var22,2)<REF(Var22,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),0.5,0);
Var26:=EMA(Var22,12)*0.7;
Var27:=EMA(Var22,3);
底部将成: IF(LLV(Var27-Var26,12)>0,0,-30),colorstick;
Var28:=EMA(CLOSE,12)-EMA(CLOSE,26);
Var29:=EMA(Var28,9);
Var2A:=2*(Var28-Var29);
抄底: IF(底部将成<0 AND CROSS(Var2A,0),50,0),colorstick;
if(抄底>0,60,1);

大智慧底部将成指标公式

 

相关文章