在线检测未来函数

通达信经典买卖主图指标公式

来源:Internet,编辑:股旁网,2013-03-09

工作线:(EMA(C,14)),POINTDOT,LINETHICK3,COLOR22ACDE;
生命线:(MA(C,25)),LINETHICK1,COLORMAGENTA;
不惑线:(MA(C,40)),COLORCYAN,LINETHICK1;
姊妹线:(EMA(C,56)),POINTDOT,COLOR33CCDD,LINETHICK1;
A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,2);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
DRAWICON(A26,(L/1.015),1),LINETHICK2,COLORMAGENTA;
DRAWTEXT(CROSS(A4,A3),L,'线上阴线买停板'),LINETHICK4,COLOR22ACDE;
STICKLINE(((C >= 工作线) AND (C >= O)),H,L,0,1),COLORRED;
STICKLINE(((C >= 工作线) AND (C >= O)),O,C,2,1),COLORRED;
STICKLINE(((C >= 工作线) AND (C <= O)),H,L,0,0),COLORRED;
STICKLINE(((C >= 工作线) AND (C <= O)),O,C,2,0),COLORRED;
STICKLINE(((C < 工作线) AND (C >= O)),H,L,0,1),COLORGREEN;
STICKLINE(((C < 工作线) AND (C >= O)),O,C,2,1),COLORGREEN;
STICKLINE(((C < 工作线) AND (C <= O)),H,L,0,0),COLORGREEN;
STICKLINE(((C < 工作线) AND (C <= O)),O,C,2,0),COLORGREEN;
七天线:MA(C,7),COLORGRAY,LINETHICK2; 涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),COLORYELLOW;
ZDF:=(C-REF(C,1))/REF(C,1)*100;VAR2S:=(2*CLOSE+HIGH+LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←吸'),COLORRED;
VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3:=MA(CLOSE,21)+2*STD(CLOSE,21);
DRAWICON(CROSS(VAR2,VAR3),HIGH*1.035,2);
DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.02,'卖出'), COLORGREEN;
VAR4:=REF(CLOSE,1);
VAR5:=SMA(MAX(CLOSE-VAR4,0),7,1)/SMA(ABS(CLOSE-VAR4),7,1)*100;
VAR6:=CROSS(79,VAR5);
VAR7:=FILTER(VAR6,4);
DRAWICON(VAR7,HIGH*1.035,2);
DRAWTEXT(VAR7,HIGH*1.02,'卖出'), COLORGREEN;

通达信经典买卖主图指标公式

 

相关文章