在线检测未来函数

大智慧三种背离现眼前指标公式

来源:Internet,编辑:股旁网,2013-03-07

SHORT:=12;LONG:=26;M:=9;N:=9;M1:=3;M2:=3;
LC := REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,colorwhite;
RSI2:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100,coloryellow;
RSI3:SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100,colorff00ff;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1),colorwhite;
D:SMA(K,M2,1),coloryellow;
J:3*K-2*D,colorff00ff;
DIFF:EMA(CLOSE,SHORT) - EMA(CLOSE,LONG),colorwhite;
DEA:EMA(DIFF,M),coloryellow;
MACD:2*(DIFF-DEA), COLORSTICK ;
A1:=BARSLAST(ref(cross(diff,dea),1));
B1:=ref(c,A1+1)>c and ref(diff,A1+1)<diff and cross(diff,dea);
DRAWTEXT(FILTER(B1>0,5),0,'MACD'),COLORGREEN;
Stickline(FILTER(B1>0,5),-1,0,1,0),COLORGREEN;
A2:=BARSLAST(ref(cross(k,d),1));
B2:=ref(c,A2+1)>c and ref(k,A2+1)<k and cross(k,d);
DRAWTEXT(FILTER(B2>0,5),0.5,'KDJ'),COLORYELLOW;
Stickline(FILTER(B2>0,5),0.5,-1,1,0),COLORYELLOW;
A3:=BARSLAST(ref(cross(RSI1,RSI2),1));
B3:=ref(c,A3+1)>c and ref(RSI1,A3+1)<RSI1 and cross(RSI1,RSI2);
DRAWTEXT(FILTER(B3>0,5),-0.25,'RSI'),COLORred;
Stickline(FILTER(B3>0,5),-1,-0.25,1,0),COLORred;
C1:=BARSLAST(ref(cross(dea,diff),1));
D1:=ref(c,C1+1)<c and ref(diff,C1+1)>diff and cross(dea,diff);
DRAWTEXT(FILTER(D1>0,5),-0.5,'MACD'),COLORwhite;
Stickline(FILTER(D1>0,5),-0.5,1,1,0),COLORwhite;
C2:=BARSLAST(ref(cross(d,k),1));
D2:=ref(c,C2+1)<c and ref(k,C2+1)>k and cross(d,k);
DRAWTEXT(FILTER(D2>0,5),0,'KDJ'),COLORwhite;
Stickline(FILTER(D2>0,5),1,0,1,0),COLORwhite;
C3:=BARSLAST(ref(cross(RSI2,RSI1),1));
D3:=ref(c,C3+1)<c and ref(RSI1,C3+1)>RSI1 and cross(RSI2,RSI1);
DRAWTEXT(FILTER(D3>0,5),0.25,'RSI'),COLORblue;
Stickline(FILTER(D3>0,5),1,0.25,1,0),COLORblue;

大智慧三种背离现眼前指标公式

 

相关文章