在线检测未来函数

通达信股市振荡波指标公式

来源:Internet,编辑:股旁网,2013-03-14

var0:=(((LOW + HIGH) + CLOSE) / 3);
VAR4T:=MA(var0,5);
操作T:=HHV(VAR4T,13);
拉升T:=LLV(VAR4T,13);
买卖T:=(0 - (((操作T - VAR4T) / VAR4T) * 100));
J1T:=(0 - (((操作T - 拉升T) / 拉升T) * 100));
J2T:=(买卖T - J1T);
J3T:=IF((买卖T < (0 - 15)),(买卖T + 15),0);
DBXJ1:=IF(((买卖T < (0 - 10)) AND (J1T < (0 - 15))),(J1T + 15),0);
DBXJ2:=((J3T + DBXJ1) / 2);
D:IF((DBXJ2 > 0),0,DBXJ2),POINTDOT;
DBXJ:=INTPART((((SMA(MAX((CLOSE - REF(CLOSE,1)),0),6,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),6,1)) * 10) - 2));
N:IF((DBXJ < 0),0,DBXJ),POINTDOT;
STICKLINE((DBXJ2 < (0 - 50)),0,(0 - 60),10,0),colorFF00FF;
STICKLINE((DBXJ2 < (0 - 40)),0,(0 - 50),10,0);
STICKLINE((DBXJ2 < (0 - 30)),0,(0 - 40),10,0);
STICKLINE((DBXJ2 < (0 - 20)),0,(0 - 30),10,0);
STICKLINE((DBXJ2 < (0 - 10)),0,(0 - 20),10,0),colorFFFF00;
STICKLINE((DBXJ2 < 0),0,(0 - 10),10,0),colorFFFFFF;
STICKLINE((DBXJ > 5),0,60,10,0),colorFF00FF;
STICKLINE((DBXJ > 4),0,50,10,0);
STICKLINE((DBXJ > 3),0,40,10,0);
STICKLINE((DBXJ > 2),0,30,10,0);
STICKLINE((DBXJ > 1),0,20,10,0),colorFFFF00;
STICKLINE((DBXJ > 0),0,10,10,0),colorFFFFFF;
A:STICKLINE((CLOSE > 0),(0 - 3),3,10,0),colorFF0000;
初选范围:10*IF(((D < 0) OR (REF(D,1) < 0)),1,0),POINTDOT,color808080;
出击时机:10*IF((((N > REF(N,1)) AND ((N = 1) OR (N = 2))) AND ((D < 0) OR (REF(D,1) < 0))),1,0),POINTDOT;
Var1:=(HIGH+LOW+CLOSE)/3;
Var2:=(Var1-MA(Var1,14))/(0.015*AVEDEV(Var1,14));
Var3:=(Var1-MA(Var1,70))/(0.015*AVEDEV(Var1,70));
Var4:=IF(Var2>=150 AND Var2<200 AND Var3>=150 AND Var3<200,-10,0);
Var5:=IF(Var2<=-150 AND Var2>-200 AND Var3<=-150 AND Var3>-200,10,0);
天线:IF(BARSCOUNT(CLOSE)<70,120,IF(Var3>=200 AND Var2>=150,-15,Var4)+120),Linethick2,colorccff66;
地线:IF(BARSCOUNT(CLOSE)<70,-120,IF(Var3<=-200 AND Var2<=-150,15,Var5)-120),Linethick2,colorff99cc;
Var6:=SMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,4,1);
var60:SMA((Var6-50)*2,3,1),Linethick2,colorff0033;
Var7:=SMA((CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100,4,1);
var70:SMA((Var7-50)*2,3,1),Linethick2,colorff2233;
var71:(SMA((Var7-50)*2,3,1)+SMA((Var6-50)*2,3,1))/2,Linethick2,colorff4433;
Var8:=SMA((CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100,4,1);
var80:SMA((Var8-50)*2,3,1),Linethick2,colorff6633;
VAR81:(SMA((Var8-50)*2,3,1)+SMA((Var7-50)*2,3,1))/2,Linethick2,colorff8833;
Var9:=SMA((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100,4,1);
Vara:SMA((Var9-50)*2,3,1),Linethick2,colorff9933;
VARb:(SMA((Var9-50)*2,3,1)+SMA((Var8-50)*2,3,1))/2,Linethick2,colorffaa33;
Var10:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);
VAR100:SMA((Var10-50)*2,3,1),Linethick2,colorffbb33;
Var11:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);
波浪线:SMA((Var11-50)*2,3,1)+SMA((Var10-50)*2,3,1)/2,COLORSTICK,color888888;
Var12:=(Var11-50)*6-2*SMA((Var11-50)*2,3,1);
Var13:=FILTER(波浪线>REF(波浪线,1)AND 波浪线<-20,10);
Var14:=FILTER(波浪线<REF(波浪线,3)AND 波浪线>REF(波浪线,1)AND 波浪线<-10,7);
Var15:=FILTER(波浪线<REF(波浪线,1),10);
Var16:=FILTER(波浪线<REF(波浪线,1)AND 波浪线>110,10);
Var17:=Var11<REF(Var11,3)AND Var11>REF(Var11,2)AND Var11<30;
DRAWICON(FILTER(Var13 OR Var14 OR Var17,5)AND Vara>REF(Vara,1),波浪线,1);
DRAWICON(FILTER(CROSS(波浪线,Var12)OR Var15,5)AND Var12>60,波浪线*1.05,2);
DRAWTEXT(FILTER(CROSS(100,波浪线)OR Var16,3),110,'顶部'),COLOR00FF00;
DRAWTEXT(CROSS(波浪线,地线),地线*0.6,'抄底'),colorred;

通达信股市振荡波指标公式

 

相关文章