在线检测未来函数

通达信光哥主图指标公式

来源:Internet,编辑:股旁网,2013-03-16

LY:=10;
BL:=40;
CJQS:=XMA(CLOSE,LY);
JBQS:=XMA(CLOSE,BL);
N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT);
M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT);
JB上轨:=IF(CURRBARSCOUNT>BL/2,JBQS*1.1,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*1.1);
JB下轨:=IF(CURRBARSCOUNT>BL/2,JBQS*0.9,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*0.9);
CJ上轨:=IF(CURRBARSCOUNT>LY/2,CJQS*1.05,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*1.05);
CJ下轨:=IF(CURRBARSCOUNT>LY/2,CJQS*0.95,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*0.95);
DRAWTEXT(O<=CJ下轨,(L * 0.99),'←加仓'),COLORMAGENTA;
DRAWTEXT(CROSS(H,CJ上轨),(H * 1.01),'震仓'),COLORYELLOW;
DRAWTEXT(CROSS(CJ下轨,L),(L * 0.90),'补'),COLORBLACK;
DRAWTEXT(O<=CJ下轨 AND CJ下轨<JB下轨,(L * 0.93),'←绝杀'),COLORRED;
DRAWTEXT(CROSS(H,CJ上轨) AND CJ上轨>JB上轨,(H * 1.04),''),COLORGREEN;
DRAWTEXT(O<=JB下轨,(L * 0.96),'←涨'),COLORYELLOW;
DRAWTEXT(O<=JB下轨 AND C>JB下轨,(L * 0.91),'←黑马'),COLORWHITE;
R1:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);{ZIG 有未来}
R2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);
STICKLINE(R1,C,O,3,0),COLORBLUE,LINETHICK1;{高位兰色}
STICKLINE(R1,C,O,2,0),COLORBLUE,LINETHICK1;{高位兰色}
STICKLINE(R1,H,L,1,0),COLORBLUE,LINETHICK1;{高位兰色}
STICKLINE(R2,C,O,3,0),COLORFF00FF,LINETHICK1;{底位红色}
STICKLINE(R2,C,O,2,0),COLORFF00FF,LINETHICK1;{底位红色}
STICKLINE(R2,H,L,1,0),COLORFF00FF,LINETHICK1;{底位红色};
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);
白龙:= MA(CLOSE,125);
黄龙:= 白龙+2*STD(CLOSE,170);
紫龙:= 白龙-2*STD(CLOSE,145);
青龙: SAR(125,1,7);
VAR42:=HHV(HIGH,70);
VAR43:=HHV(HIGH,20);
红龙:= VAR42*0.83;
蓝龙:= VAR43*0.91;
T1B:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T1B));
CC:=CONST(CURRBARSCOUNT);
T2B:=CONST(BARSLAST(CURRBARSCOUNT>CC+T1B AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T2B));
T3:=CONST(BARSLAST(CURRBARSCOUNT>CC+T2B AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T3));
必杀线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),COLORRED,LINETHICK3;{,LINETHICK2,COLOR0000FF;}
DRAWTEXT(ISLASTBAR, T3HIGH, '必杀线')LINETHICK1,COLOR0000FF;
MA5K:必杀线,COLORYELLOW,LINETHICK1;
DRAWICON(CROSS(CLOSE,必杀线),LOW*0.97,13);
M1:=5;M2:=10;M3:=30;M4:=60;
MA1:=MA(CLOSE,M1);
MA2:=MA(CLOSE,M2);
MA3:=MA(CLOSE,M3);
MA4:=MA(CLOSE,M4);
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.97,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
N1:=5;N2:=10;
LC:=REF(CLOSE,1);
A0:=(2*C+H+L)/4;
均线:=MA(A0,3)>REF(MA(A0,3),1);
安全线:=2,COLORRED,POINTDOT,LINETHICK4;
A1:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;
K:=MA(3*SMA(A1,6,1)-2*SMA(SMA(A1,5,1),5,1),3),LINETHICK1,COLORF00FF0;
D:=MA(K,3),COLORFF0000,LINETHICK1;
J:=3*K-2*D,LINETHICK1,COLORF00FF0;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00;
BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
底线:=0,COLORFF00FF;
顶线:=10,COLORFF0000;
TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9),COLORFFFF00;
A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A11+1)>CLOSE AND DIFF>REF(DIFF,A11+1) AND CROSS(DIFF,DEA);
BB:IF(底背离,LOW*0.97,DRAWNULL),CROSSDOT,LINETHICK3,COLORRED;

通达信光哥主图指标公式

 

相关文章