在线检测未来函数

通达信回头是岸指标公式

来源:Internet,编辑:股旁网,2013-04-01

N:=14;N1:=7;P:=5;
AA1:=(C)/MA(C,3)*100;
QS1:=DMA(AA1,V/CAPITAL),COLORWHITE,LINETHICK2;
BB1:=MA(C,3)/C*100;
QS2:=DMA(BB1,V/CAPITAL);
QS:QS1-QS2,COLORRED,LINETHICK2;
0;
RSI1:=QS,COLORRED,LINETHICK2;
AA:=REF(RSI1,N)=HHV(RSI1,2*N+1);
BB:=BACKSET(AA,N+1);
CC:=FILTER(BB,N) AND RSI1=HHV(RSI1,N+1);
A11:=BARSLAST(REF(CC,1));
背离:=REF(CLOSE,A11+1)<CLOSE AND REF(RSI1,A11+1)>RSI1 AND CC;
DRAWLINE(CC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORGREEN,LINETHICK2;
AA2:=REF(RSI1,N)=LLV(RSI1,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND RSI1=LLV(RSI1,N+1);
A22:=BARSLAST(REF(CC2,1));
底背离:=REF(CLOSE,A22+1)>CLOSE AND REF(RSI1,A22+1)<RSI1 AND CC2;
DRAWLINE(CC2,RSI1,FILTER(底背离>0,5),RSI1,0),COLORMAGENTA,LINETHICK2;
AAA:=REF(RSI1,N1)=HHV(RSI1,2*N1+1);
BBB:=BACKSET(AAA,N1+1);
CCC:=FILTER(BBB,N1) AND RSI1=HHV(RSI1,N1+1);
AA11:=BARSLAST(REF(CCC,1));
顶背离7:=REF(CLOSE,AA11+1)<CLOSE AND REF(RSI1,AA11+1)>RSI1 AND CCC;
DRAWLINE(CCC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORGREEN,LINETHICK2;
AAA2:=REF(RSI1,N1)=LLV(RSI1,2*N1+1);
BBB2:=BACKSET(AAA2,N1+1);
CCC2:=FILTER(BBB2,N1) AND RSI1=LLV(RSI1,N1+1);
AA22:=BARSLAST(REF(CCC2,1));
底背离7:=REF(CLOSE,AA22+1)>CLOSE AND REF(RSI1,A22+1)<RSI1 AND CCC2;
DRAWLINE(CCC2,RSI1,FILTER(底背离>0,5),RSI1,0),COLORMAGENTA,LINETHICK2;
A1:=REF(RSI1,P)=HHV(RSI1,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);{高点}
A2:=REF(RSI1,P)=LLV(RSI1,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);{低点}
前期高点:REF(RSI1,BARSLAST(D1)),COLORFF00FF,NODRAW;
前期低点:REF(RSI1,BARSLAST(D2)),COLOR00FF00,NODRAW;
向前期高点:CROSS(RSI1,前期高点*1.01),NODRAW;
相对能量:(RSI1-前期低点)/(前期高点-前期低点)*100,COLORYELLOW,NODRAW;
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
DRAWLINE(D1,RSI1,S11,RSI1,1),COLORYELLOW;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
DRAWLINE(D2,RSI1,U11,RSI1,1),COLOR00FF00;
STICKLINE(C>0,前期低点,前期低点,1,0),COLOR00FF00;
STICKLINE(C>0,前期高点,前期高点,1,0),COLORFF00FF;

通达信回头是岸指标公式

 

相关文章