在线检测未来函数

通达信买卖2线指标公式

来源:Internet,编辑:股旁网,2013-04-02

ZTBL:=REF(ZIG(3,13),3)>REF(ZIG(3,13),2)AND REF(ZIG(3,13),1)>REF(ZIG(3,13),2);
BL:= REF(ZIG(3,13),2)>REF(ZIG(3,13),1) AND ZIG(3,13)>REF(ZIG(3,13),1);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND
REF(ZIG(3,6),2)<=REF(ZIG(3,6),3) ;
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND
REF(ZIG(3,6),2)>=REF(ZIG(3,6),3) ;
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)
AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3) ;
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2)
AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3) ;
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2)
AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3) ;
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2)
AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3) ;
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)
AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3) ;
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2)
AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3) ;
组合买:=(VAR13+VAR15+VAR17) ;
买一:VAR11,LINETHICK1,COLORGREEN ;
买二:IF(ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF
(ZIG(3,10),2),2,0),COLORRED;
买三:IF(BL=1,3,0),LINETHICK1,COLORYELLOW;
买四:IF (BL AND 组合买,4,0),LINETHICK2,COLORRED;
卖一:IF(VAR12,5,6),LINETHICK1,COLORGREEN ;
卖二:IF(ZIG(3,10
)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2),
4,6),COLORRED;
卖三:IF(REF(ZIG(3,13),2)<REF(ZIG(3,13),1) AND ZIG(3,13)<REF(ZIG(3,13),1),
3,6),LINETHICK1,COLORYELLOW;
卖四:IF((VAR14+VAR16+VAR18),1.5,6) ,LINETHICK2,COLORRED;

通达信买卖2线指标公式

 

相关文章