在线检测未来函数

通达信精进终极双周期主图指标公式

来源:Internet,编辑:股旁网,2013-04-19

精进终极是一个较好的指标。推荐指标使用双周期原理,对长短周期突破的识别有较好效果。为了进一步确认突破的有效性,建议朋友们:在使用该指标的同时参考成交量类指标。

A0:=(L+H+C*2)/4;
A1:EMA(A0,14),COLORBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100;
G1:=BARSLAST(CROSS(A1X,0));
买入止损:=REF(A0,G1),COLORWHITE,LINETHICK1;
买入盈利:(A0-买入止损)/买入止损*100,NODRAW;
IF(A1X>=0,买入止损,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(A1X>=0,A1,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(H>=REF(A0,G1)*1.1,REF(A0,G1)*1.1,DRAWNULL),COLORBLUE,POINTDOT;
IF(H>=REF(A0,G1)*1.2,REF(A0,G1)*1.2,DRAWNULL),COLORBLUE,POINTDOT;
IF(H>=REF(A0,G1)*1.3,REF(A0,G1)*1.3,DRAWNULL),COLORBLUE,CIRCLEDOT;
IF(H>=REF(A0,G1)*1.4,REF(A0,G1)*1.4,DRAWNULL),COLORBLUE,POINTDOT;
IF(H>=REF(A0,G1)*1.5,REF(A0,G1)*1.5,DRAWNULL),COLORBLUE,POINTDOT;
IF(H>=REF(A0,G1)*1.6,REF(A0,G1)*1.6,DRAWNULL),COLORBLUE,POINTDOT;
IF(H>=REF(A0,G1)*1.7,REF(A0,G1)*1.7,DRAWNULL),COLORBLUE,POINTDOT;
B1:EMA(A0,14*5),COLORGREEN,LINETHICK2;
B1X:=(B1-REF(B1,1*5))/REF(B1,1*5)*100;
BG1:=BARSLAST(CROSS(B1X,0));
买入止损B:=REF(A0,BG1),COLORWHITE,LINETHICK1;
买入盈利B:(A0-买入止损B)/买入止损B*100,NODRAW;
IF(B1X>=0,买入止损B,DRAWNULL),COLORRED,LINETHICK2;
IF(B1X>=0,B1,DRAWNULL),COLORRED,LINETHICK2;
IF(H>=REF(A0,BG1)*1.1,REF(A0,BG1)*1.1,DRAWNULL),COLORGREEN,POINTDOT;
IF(H>=REF(A0,BG1)*1.2,REF(A0,BG1)*1.2,DRAWNULL),COLORGREEN,POINTDOT;
IF(H>=REF(A0,BG1)*1.3,REF(A0,BG1)*1.3,DRAWNULL),COLORGREEN,CIRCLEDOT;
IF(H>=REF(A0,BG1)*1.4,REF(A0,BG1)*1.4,DRAWNULL),COLORGREEN,POINTDOT;
IF(H>=REF(A0,BG1)*1.5,REF(A0,BG1)*1.5,DRAWNULL),COLORGREEN,POINTDOT;
IF(H>=REF(A0,BG1)*1.6,REF(A0,BG1)*1.6,DRAWNULL),COLORGREEN,POINTDOT;
IF(H>=REF(A0,BG1)*1.7,REF(A0,BG1)*1.7,DRAWNULL),COLORGREEN,POINTDOT;

通达信精进终极双周期主图指标公式

 

相关文章