在线检测未来函数

大智慧一线天指标公式

来源:Internet,编辑:股旁网,2013-05-21

黄线为委卖5档的总和,白线为委买5档的总和,粉红色粗线为委买5档总和与委卖5档总和的差值,粉红色线在0轴上是委卖更强,在0轴之下是委买更强。

variable:tr=0;
N1:=1;
MB:=0.2;
MM:=2.7;
TR1:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=EMA(TR1,N1);
median:= (high + low + close) / 3;
up:= median+atr * MB;
dn:= median-atr * MB;
tr:=if(c>=ref(up,1),1,if(c<=ref(dn,1),-1,TR));
flag:=tr<0 and ref(tr,1)>0;
flagh:=tr>0 and ref(tr,1)<0;
up1:=if(flag,median + atr * MM,up);
dn1:=if(flagh,median - atr * MM,dn);
outtr:if(barpos=1 and c>o,1,if(barpos=1 and c<=o,-1,tr)),PRECIS0,linethick0;
outup:=IF(up1/H>1.05,REF(UP1,1),UP);
outdn:=IF(L/dn1>1.05,REF(DN1,1),DN);
supertren:if(outtr=1,outdn,outup);
PARTLINE(supertren,tr=1,rgb(255,0,0),tr=-1,rgb(0,255,255)),layer0,linethick4;

大智慧一线天指标公式

 

相关文章