在线检测未来函数

通达信4S专用OBV指标公式

来源:Internet,编辑:股旁网,2013-06-03

M:=30;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0),COLORWHITE,LINETHICK4;
MAOBV:MA(OBV,M),COLOR00FF00,LINETHICK1.999;
DRAWBAND(OBV,RGB(50,50,120),MAOBV,RGB(00,50,00));
UPOBV:=IF(OBV>=REF(OBV,1) AND OBV>=MAOBV,OBV,DRAWNULL);
DRAWBAND(UPOBV,RGB(50,20,20),MAOBV,RGB(00,50,00));
HIGHN:=5;
LOWN:=HIGHN;
AA:=REF(OBV,HIGHN)=HHV(OBV,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND OBV=HHV(OBV,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(OBV,DDD),OBV);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,OBV,CURRBARSCOUNT=GDCS1,OBV,1),COLORGREEN,LINETHICK1,DOTLINE;
AA1:=REF(OBV,LOWN)=LLV(OBV,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND OBV=LLV(OBV,LOWN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(OBV,DD1),OBV);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,OBV,CURRBARSCOUNT=DDCS1,OBV,1),COLORRED,LINETHICK1,DOTLINE;
DRAWLINE(CURRBARSCOUNT=GDCS2,OBV,ISLASTBAR,REF(OBV,GDCS2-1),1),COLORFFFFFF,LINETHICK1.999,DOTLINE;
DRAWLINE(CURRBARSCOUNT=GDCS1,OBV,ISLASTBAR,REF(OBV,GDCS1-1),1),COLORCYAN,LINETHICK1.999,DOTLINE;
N:=10;
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
A1:=REF(OBV1,N)=HHV(OBV1,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);
T线:REF(OBV,BARSLAST(D1)),COLORFF00FF,LINETHICK0;
STICKLINE(C>0,T线,T线,6,0),COLORFF6600;
BDGD:=CROSS(0.8,H=HHV(H,4));
GDSJ:=BARSLAST(BDGD)+1;
波峰:=REF(H,GDSJ),COLOR00FF00,POINTDOT;
BDDD:=CROSS(0.8,L=LLV(L,4));
DDSJ:=BARSLAST(BDDD)+1;
波谷:=REF(L,DDSJ),COLORFF00FF,POINTDOT;
STICKLINE(OBV<=REF(OBV,波峰) AND H>REF(H,波峰),OBV,MAOBV,1,0),COLORCYAN;
STICKLINE(OBV>=REF(OBV,波峰) AND H<REF(H,波峰),OBV,MAOBV,1,0),COLORFF66FF;
IF(OBV>=REF(OBV,1) AND L<REF(L,1),OBV,DRAWNULL),COLORLIRED,LINETHICK4;
IF(OBV>=REF(OBV,波谷) AND L<REF(L,波谷),OBV,DRAWNULL),COLORRED,LINETHICK4;
HBL:=HHV(H,10);
HOBV:=HHV(OBV,10);
STICKLINE(OBV>=REF(OBV,HBL) AND H<REF(H,HBL),OBV,MAOBV,1,0),COLORFF33FF;
STICKLINE(OBV<=REF(OBV,HBL) AND H>REF(H,HBL),OBV,MAOBV,1,0),COLORCYAN;
STICKLINE(OBV>=HOBV AND H<HBL,OBV,MAOBV,1,0),COLORFF22FF;
STICKLINE(OBV<=HOBV AND H>HBL,OBV,MAOBV,1,0),COLORLIBLUE;
STICKLINE(OBV>=REF(OBV,1) AND H<REF(H,1),OBV,MAOBV,1,1),COLORLIRED;
STICKLINE(OBV<=REF(OBV,1) AND H>REF(H,1),OBV,MAOBV,1,1),COLORCYAN;
STICKLINE(CROSS(OBV,T线),T线,T线*1.03,1,0),COLORYELLOW;

通达信4S专用OBV指标公式

 

相关文章