在线检测未来函数

通达信屠龙刺客主图指标公式

来源:Internet,编辑:股旁网,2013-06-11

Var1:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)*100;
Var2:=CLOSE>OPEN AND OPEN-LOW>HIGH-CLOSE;
Var3:=REF(Var1,1)<-20 AND Var2;
Var4:=REF(Var1,1)<-20 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
Var5:=FILTER(Var3 OR Var4,3);
Var6:=OPEN>CLOSE AND HIGH-IF(CLOSE>OPEN,CLOSE,OPEN)>IF(OPEN<CLOSE,OPEN,CLOSE)-LOW;
Var7:=REF(Var1,1)>ABS(-20) AND Var6;
Var8:=REF(Var1,1)>ABS(-20) AND CLOSE<OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>20;
Var9:=FILTER(Var7 OR Var8,3);
VarA:=REF(Var1,1)<-13 AND Var2;
VarB:=REF(Var1,1)<-13 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
VarC:=FILTER(VarA OR VarB,3);
VarD:=REF(Var1,1)>ABS(-13) AND Var6;
VarE:=REF(Var1,1)>ABS(-13) AND CLOSE<OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>20;
VarF:=FILTER(VarD OR VarE,3);
DRAWICON(Var5*Var1>0,LOW,1);
DRAWICON(Var9*Var1>0,HIGH,2);
DRAWTEXT(VarC*Var1>0,1.02*REF(CLOSE,1),'关注');
DRAWTEXT(VarF*Var1>0,0.99*REF(CLOSE,1),'风险');
Var10:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1:=(EMA(Var10,3)+EMA(Var10,6)+EMA(Var10,12)+EMA(Var10,24))/4,COLOR00FF00;
A2:=EMA(A1,2);
A3:=EMA(A2,2);
A4:=EMA(A3,2);
A5:=EMA(A4,2);
A6:=EMA(A5,2);
道场:EMA(A6,2),COLOR00FF00;
生命线: EMA(CLOSE,55),COLOR0000FF;
Var11:=LLV(LOW,5);
Var12:=HHV(HIGH,4);
Var13:=EMA((Var10-Var11)/(Var12-Var11)*100,4);
Var14:=EMA(0.667*REF(Var13,1)+0.333*Var13,2);
DRAWTEXT(CROSS(Var13,Var14) AND Var13<40,LOW,'刺客'),COLOR00FFFF;
Var15:=EMA(Var10,13)-EMA(Var10,34);
Var16:=EMA(Var15,5);
Var17:=(-2)*(Var15-Var16)*3.8;
DRAWTEXT(CROSS(Var17,MA(Var17,3)) AND Var16,HIGH,'屠龙');
Var18:=(2*CLOSE+LOW+HIGH)/4;
天堂: EMA(Var18,45)*1.15,COLOR00FFFF;
地狱: EMA(Var18,40)*0.85,COLORFF0000;

通达信屠龙刺客主图指标公式

 

相关文章