在线检测未来函数

通达信S理论十格图主图指标公式

来源:Internet,编辑:股旁网,2013-06-19

DRAWTEXT_FIX(1,0.65,0.9,1,'■---------------------------------------');
DRAWTEXT_FIX(1,0.87,0.9,1,'----------------------------------------■');
DRAWTEXT_FIX(1,0.87,0.1.5,1,'----------------------------------------■');
DRAWTEXT_FIX(1,0.65,0.1.5,1,'■---------------------------------------');
DRAWTEXT_FIX(1,0.97,0.30,1,'︱');
DRAWTEXT_FIX(1,0.97,0.32,1,'︱');
DRAWTEXT_FIX(1,0.97,0.34,1,'︱');
DRAWTEXT_FIX(1,0.97,0.36,1,'︱');
DRAWTEXT_FIX(1,0.97,0.38,1,'︱');
DRAWTEXT_FIX(1,0.97,0.40,1,'︱');
DRAWTEXT_FIX(1,0.97,0.42,1,'︱');
DRAWTEXT_FIX(1,0.97,0.44,1,'︱');
DRAWTEXT_FIX(1,0.97,0.46,1,'︱');
DRAWTEXT_FIX(1,0.97,0.48,1,'︱');
DRAWTEXT_FIX(1,0.97,0.50,1,'︱');
DRAWTEXT_FIX(1,0.97,0.52,1,'︱');
DRAWTEXT_FIX(1,0.97,0.54,1,'︱');
DRAWTEXT_FIX(1,0.97,0.56,1,'︱');
DRAWTEXT_FIX(1,0.97,0.58,1,'︱');
DRAWTEXT_FIX(1,0.97,0.60,1,'︱');
DRAWTEXT_FIX(1,0.97,0.62,1,'︱');
DRAWTEXT_FIX(1,0.97,0.64,1,'︱');
DRAWTEXT_FIX(1,0.97,0.66,1,'︱');
DRAWTEXT_FIX(1,0.97,0.67,1,'︱');
DRAWTEXT_FIX(1,0.39,0.30,1,'︱');
DRAWTEXT_FIX(1,0.39,0.32,1,'︱');
DRAWTEXT_FIX(1,0.39,0.34,1,'︱');
DRAWTEXT_FIX(1,0.39,0.36,1,'︱');
DRAWTEXT_FIX(1,0.39,0.38,1,'︱');
DRAWTEXT_FIX(1,0.39,0.40,1,'︱');
DRAWTEXT_FIX(1,0.39,0.42,1,'︱');
DRAWTEXT_FIX(1,0.39,0.44,1,'︱');
DRAWTEXT_FIX(1,0.39,0.46,1,'︱');
DRAWTEXT_FIX(1,0.39,0.48,1,'︱');
DRAWTEXT_FIX(1,0.39,0.50,1,'︱');
DRAWTEXT_FIX(1,0.39,0.52,1,'︱');
DRAWTEXT_FIX(1,0.39,0.54,1,'︱');
DRAWTEXT_FIX(1,0.39,0.56,1,'︱');
DRAWTEXT_FIX(1,0.39,0.58,1,'︱');
DRAWTEXT_FIX(1,0.39,0.60,1,'︱');
DRAWTEXT_FIX(1,0.39,0.62,1,'︱');
DRAWTEXT_FIX(1,0.39,0.64,1,'︱');
DRAWTEXT_FIX(1,0.39,0.66,1,'︱');
DRAWTEXT_FIX(1,0.39,0.67,1,'︱');
DRAWRECTREL(198,500,1200,501,200);
DRAWRECTREL(198,700,1200,701,200);
DRAWRECTREL(198,300,1200,301,200);
DRAWRECTREL(675,100,676,990,200);
DRAWRECTREL(485,100,486,990,200);
DRAWRECTREL(865,100,866,990,200);
DRAWTEXT_FIX(1,0.71,0.95,1,'触底信号'),COLORYELLOW;
DRAWTEXT_FIX(1,0.96,0.88,1,'买进信号'),COLORYELLOW;
DRAWTEXT_FIX(1,0.93,0.48,1,'加仓'),COLORYELLOW;
DRAWTEXT_FIX(1,0.96,0.20,1,'高抛'),COLORYELLOW;
DRAWTEXT_FIX(1,0.71,0.08,1,'冲顶信号'),COLORYELLOW;
DRAWTEXT_FIX(1,0.44,0.10,1,'减磅信号'),COLORYELLOW;
DRAWTEXT_FIX(1,0.43,0.48,1,'清仓'),COLORYELLOW;
DRAWTEXT_FIX(1,0.43,0.88,1,'低吸'),COLORYELLOW;
DRAWTEXT_FIX(1,0.39,0.27,1,'■');
DRAWTEXT_FIX(1,0.39,0.70,1,'■');
DRAWTEXT_FIX(1,0.97,0.27,1,'■');
DRAWTEXT_FIX(1,0.97,0.70,1,'■');
涨幅1:=(C-REF(C,1))/REF(C,1);
量涨幅1:=(V-REF(V,1))/REF(V,1);
价涨幅:=SUM(价涨幅1,0);
量涨幅:=SUM(量涨幅1,0);
量涨幅2:=MA(量涨幅,50)/MA(价涨幅,20);
量涨幅线:=量涨幅/量涨幅2;
A1:=CROSS(价涨幅,0) OR CROSS(价涨幅,量涨幅);
A2:=V>MA(V,20);
A3:=C/REF(C,1)*100-100>-1 AND C/REF(C,1)*100-100<3.5;
A4:=CURRBARSCOUNT=1;
买入信号:=A1+A2+A3+A4;
DRAWNUMBER_FIX(买入信号=4,0.96,0.85,1,C),COLORLIRED;
A5:=V/MA(V,20)>2;
加仓:=买入信号+A5;
DRAWNUMBER_FIX(加仓=5,0.91,0.45,1,C),COLORLIRED;
观望1:=C>REF(C,1) AND V>REF(V,1);
DRAWNUMBER_FIX(观望1=1 AND A4,0.96,0.16,1,C),COLORLIRED;
警戒:=C>REF(C,1) AND V<MA(V,5);
DRAWNUMBER_FIX(警戒=1 AND A4,0.78,0.08,1,C),COLORLIRED;
卖出:=C<REF(C,1) AND V<REF(V,1);
DRAWNUMBER_FIX(卖出=1 AND A4,0.48,0.10,1,C),COLORCYAN;
清仓:=C<REF(C,1) AND V>REF(V,1) AND C<MA(C,5);
DRAWNUMBER_FIX(清仓=1 AND A4,0.48,0.48,1,C),COLORCYAN;
阳转:=C<MA(C,60) AND C>REF(C,1) AND V>MA(V,5);
DRAWNUMBER_FIX(阳转=1 AND A4,0.76,0.95,1,C),COLORLIRED;
DRAWKLINE(H,O,L,C);

通达信S理论十格图主图指标公式

 

相关文章