在线检测未来函数

通达信神秘主图指标公式

来源:Internet,编辑:股旁网,2013-06-20

攻击线:=EMA((2*CLOSE+HIGH+LOW)/4,5)COLORGREEN;
生命线:EMA((2*CLOSE+HIGH+LOW)/4,13)COLORGREEN,LINETHICK2;
决策线:REF(EMA((LOW+CLOSE+OPEN)/3,25),1)LINETHICK3,COLORGREEN;
牛熊线:(EMA(LOW,125)+EMA((CLOSE+LOW)/2,125))/2,COLORGREEN,POINTDOT;
日:=150;
高1:=HHV(H,日);
低1:=LLV(L,日);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:IF(CURRBARSCOUNT<=高1,CONST(高1),DRAWNULL),COLORWHITE;
{一0.809:IF(CURRBARSCOUNT<=高1,CONST(H1),DRAWNULL),COLORMAGENTA;}
二0.618:IF(CURRBARSCOUNT<=高1,CONST(H2),DRAWNULL),COLORGREEN;
三0.500:IF(CURRBARSCOUNT<=高1,CONST(H3),DRAWNULL),COLORGRAY;
四0.382:IF(CURRBARSCOUNT<=高1,CONST(H4),DRAWNULL),COLORMAGENTA;
{五0.191:IF(CURRBARSCOUNT<=高1,CONST(H5),DRAWNULL),COLORWHITE;}
底:IF(CURRBARSCOUNT<=高1,CONST(低1),DRAWNULL),COLORYELLOW;
IF(攻击线>=REF(攻击线,1),EMA((2*CLOSE+HIGH+LOW)/4,5),DRAWNULL),LINETHICK1,COLORRED;
IF(EMA((2*CLOSE+HIGH+LOW)/4,10)>REF(EMA((2*CLOSE+HIGH+LOW)/4,13),1),EMA
((2*CLOSE+HIGH+LOW)/4,13),DRAWNULL),LINETHICK2,COLORRED;
IF(EMA((LOW+CLOSE+OPEN)/3,28)>REF(EMA((LOW+CLOSE+OPEN)/3,28),1),REF(EMA
((LOW+CLOSE+OPEN)/3,25),1),DRAWNULL),LINETHICK3,COLORRED;
IF((EMA(LOW,125)+EMA((CLOSE+LOW)/2,250))/2>REF((EMA(LOW,125)+EMA((CLOSE+LOW)/2,250))/2,1),(EMA(LOW,125)+EMA
((CLOSE+LOW)/2,125))/2,DRAWNULL),POINTDOT,COLORRED;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA), COLORSTICK,LINETHICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
DRAWTEXT(低位金叉,L*0.97,'叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWTEXT(二次金叉,L*0.93,'二叉'),COLORYELLOW;
AA1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,AA1+1)>CLOSE AND DIFF>REF(DIFF,AA1+1) AND CROSS(DIFF,DEA);
DRAWTEXT(底背离,L*0.9,'底背'),COLORFF00FF;
AA2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,AA2+1)<CLOSE AND REF(DIFF,AA2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,L*0.88,'三全'),COLORWHITE,LINETHICK2;
学学看:=MA((3*SMA((C-LLV(L,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1),3,1)),2);
DRAWTEXT(CROSS(学学看,0),L*0.95,'秘'),COLORWHITE;

通达信神秘主图指标公式

 

相关文章