在线检测未来函数

通达信三线战备主图指标公式

来源:Internet,编辑:股旁网,2013-07-16

N:=15;
M:=32;
{stickline(c>0,-10,110,100,0),color550033;}
trtr:= MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
a:=ema(trtr,20)*2;
b:=hhv(c-a,20);
红线卖要跌:if((c>b or c=b),c,b),color0000ff,linethick3;
黄线买要涨:if(c<b,c,b),coloryellow,linethick3;
gg:c,color550033,linethick3;
Var444:=c;
操作:=MA(Var444,5);
收盘破此线短逃:HHV(操作,13),LINETHICK4,COLORffb9cc;
stickline(c>收盘破此线短逃,L,H,0.1,1),colorred;
stickline(c>收盘破此线短逃,C,O,6,1),colorred;
stickline(c>收盘破此线短逃,C,O,8,1),COLORred;
stickline(c<收盘破此线短逃,C,O,8,1),colorffff00;
stickline(c<收盘破此线短逃,C,O,6,1),color00ff00;
stickline(c<收盘破此线短逃,L,H,0.1,1),color00ff00;
Var1:=DMA(AMOUNT/VOL/100, VOL/CAPITAL);
Var2:=MA(WINNER(HIGH)-WINNER(Var1), N);
Var3:=MA(WINNER(LOW)-WINNER(Var1), M);
Var4:=Var3-Var2;
DRAWTEXT(REF(Var4,2)<REF(Var4,1) AND REF(Var4,1)>Var4 AND Var4>0 AND
Var4*10>1,l*0.98,'入'),coloryellow;
DRAWTEXT(REF(Var4,2)<REF(Var4,1) AND REF(Var4,1)>Var4 AND Var4>0 AND
Var4*10>1,l*0.95,'点'),coloryellow;
DRAWTEXT(REF(Var4,2)<REF(Var4,1) AND REF(Var4,1)>Var4 AND Var4>0 AND
Var4*10<1 AND Var4*10>0.55,l*0.98,'入'),colorgreen;
DRAWTEXT(REF(Var4,2)<REF(Var4,1) AND REF(Var4,1)>Var4 AND Var4>0 AND
Var4*10<1 AND Var4*10>0.55,l*0.95,'2'),colorgreen;
DRAWTEXT(REF(Var4,2)<REF(Var4,1) AND REF(Var4,1)>Var4 AND Var4>0 AND
Var4*10<=0.55,l*0.98,'入'),coloryellow;
DRAWTEXT(REF(Var4,2)<REF(Var4,1) AND REF(Var4,1)>Var4 AND Var4>0 AND
Var4*10<=0.55,l*0.95,'1'),coloryellow;

通达信三线战备主图指标公式

 

相关文章