在线检测未来函数

通达信横空操盘线指标公式

来源:Internet,编辑:股旁网,2013-07-22

H1:=REF(HIGH,1);
H2:=REF(HIGH,2);
H3:=REF(HIGH,3);
H4:=REF(HIGH,4);
H5:=REF(HIGH,5);
H6:=REF(HIGH,6);
H7:=REF(HIGH,7);
H8:=REF(HIGH,8);
H9:=REF(HIGH,9);
H10:=REF(HIGH,10);
H11:=REF(HIGH,11);
H12:=REF(HIGH,12);
H13:=REF(HIGH,13);
H14:=REF(HIGH,14);
L1:=REF(LOW,1);
L2:=REF(LOW,2);
L3:=REF(LOW,3);
L4:=REF(LOW,4);
L5:=REF(LOW,5);
L6:=REF(LOW,6);
L7:=REF(LOW,7);
L8:=REF(LOW,8);
D1:=HIGH>H1 AND LOW>=L1
AND CLOSE>REF(CLOSE,1);
D11:=HIGH>H1 AND LOW>=L1
AND CLOSE<=REF(CLOSE,1);
D2:=LOW<L1 AND HIGH<H1;
D3:=HIGH>H1 AND LOW<L1
AND CLOSE>REF(CLOSE,1);
D31:=HIGH>H1 AND LOW<L1
AND CLOSE<=REF(CLOSE,1);
D4:=HIGH<=H1 AND LOW>=L1;
FR1:SUM(IF(D1,HIGH,IF(D11,LOW,IF(D2,-HIGH,IF(D3,
HIGH,IF(D31,-HIGH,IF(D4,0,0)))))),0)/100,LINETHICK3,COLORGREEN;
UF1:=FR1<REF(FR1,1)
AND REF(FR1,1)>=REF(FR1,2);
UF2:=FR1=REF(FR1,1)
AND REF(FR1,1)>REF(FR1,2)
AND REF(FR1,2)<REF(FR1,3);
UFF:=UF1 OR UF2;
ZQ:=BARSLAST(UFF)+1;
DF:=FR1>REF(FR1,1)
AND REF(FR1,1)<=REF(FR1,2);
ZQ1:=BARSLAST(DF)+1;{
NOTEXT:IF(FR1<REF(FR1,1),FR1,DRAWNULL),LINETHICK5,COLORGREEN;}
上升:IF(FR1>=REF(FR1,1),FR1,DRAWNULL),LINETHICK3,COLORRED;
下降:IF(FR1<REF(FR1,1),FR1,DRAWNULL),LINETHICK3,COLORGREEN;
{
MA1:MA(FR1,10);
MA2:MA(MA1,30);};

通达信横空操盘线指标公式

 

相关文章