在线检测未来函数

通达信风云变色指标公式

来源:Internet,编辑:股旁网,2013-07-31

V1:=IF(DATE<1140730,1,0);
顶:=85*V1;
中:=50*V1;
底:=20*V1;
VAR1:=HHV(HIGH,9)-LLV(LOW,9)*V1;
VAR2:=HHV(HIGH,9)-CLOSE*V1;
VAR3:=CLOSE-LLV(LOW,9)*V1;
VAR4:=VAR2/VAR1*100-70*V1;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100*V1;
VAR6:=(2*CLOSE+HIGH+LOW)/4*V1;
VAR7:=SMA(VAR3/VAR1*100,3,1)*V1;
VAR8:=LLV(LOW,34)*V1;
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1)*V1;
VARA:=IF(VAR9>100,VAR9-100,0)*V1;
VARB:=HHV(HIGH,34)*V1;
AA:= VARA*2*V1;
BB:= EMA((VAR6-VAR8)/(VARB-VAR8)*100,13)*V1;
VARC:=EMA(0.667*REF(BB,1)+0.333*BB,2)*V1;
CC:=SMA(VAR5,20,1)*V1,COLORRED;
CC1:=SMA(CC,5,1)*V1,COLORGREEN;
IF(CC<REF(CC,1),CC,DRAWNULL),COLORBLUE,LINETHICK1;
IF(CC>REF(CC,1),CC,DRAWNULL),COLORRED,LINETHICK1;
IF(CC1<REF(CC1,1),CC1,DRAWNULL),COLORBLUE,LINETHICK1;
IF(CC1>REF(CC1,1),CC1,DRAWNULL),COLORRED,LINETHICK1;
STICKLINE(CC>CC1,CC,CC1,1,0)*V1,COLORRED;
STICKLINE(CC1>CC,CC,CC1,1,0)*V1,COLORBLUE;
出击:IF((CROSS(CC,CC1) AND (CC1 < 顶) ),80,0),COLORRED;
DRAWICON(CC < REF(CC,1) AND REF(CC,1) < REF(CC,2) AND CC > CC1,100,2);
DRAWICON(CROSS(CC1,CC),100,15);

通达信风云变色指标公式

 

相关文章