在线检测未来函数

通达信波段循环指标公式

来源:Internet,编辑:股旁网,2013-08-19

结合了kdj和波段王两个指标。有波段买点,持仓区空仓区。底部和顶部区域,短中长趋势尽在其中。

VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR2:=SUMBARS(VOL, CAPITAL);
VAR3:=HHV(VAR1,VAR2);
VAR4:=LLV(VAR1,VAR2);
VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);
VAR6:=(VAR1-VAR4)/(VAR3-VAR4);
VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);
趋势循环: IF(VAR7>0,VAR7+20,20),LINETHICK0,COLORYELLOW;
VAR8:=600*(EMA(CLOSE,5)-EMA(LOW,55))/EMA(LOW,55);
VAR9:=EMA(VAR8,7);
VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
波段买入: IF(VARA+VARB<7 AND CROSS(VAR8,VAR9) AND VAR9<-18 AND VAR9<VARB,60,50),COLORCYAN;
DRAWICON(波段买入=60,70,3);
VARC:=HHV(HIGH,9)-LLV(LOW,9);
VARD:=HHV(HIGH,9)-CLOSE;
VARE:=CLOSE-LLV(LOW,9);
VARF:=VARD/VARC*100-70;
VAR10:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
VAR11:=(2*CLOSE+HIGH+LOW)/4;
VAR12:=SMA(VARE/VARC*100,3,1);
VAR13:=LLV(LOW,34);
VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);
VAR15:=IF(VAR14>100,VAR14-100,0);
VAR16:=HHV(HIGH,34);
VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);
VAR18:=EMA(VAR17,5);
STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,0),COLORRED;
STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1),COLORGREEN;
VAR21:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
VAR22:=REVERSE(VAR21);
VAR23:=SMA(VAR21,13,1);
K1: SMA(VAR23,5,1), LINETHICK1,COLORBLUE;
RSV3:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100,;
K3:SMA(RSV3,3,1),COLORFFEC2B;
D3:SMA(K3,3,1),;
VAR24:=100*(WINNER(H)), ,;
VAR25:=EMA(VAR24,3),,;
VAR26:=EMA(VAR24,5),,;
持仓区:STICKLINE(VAR25>VAR26,100 ,105,5,1 ) COLORRED LINETHICK4;
空仓区:STICKLINE(VAR25<VAR26,100 ,105,5,1 ) COLORGREEN LINETHICK4;
STICKLINE(VAR25>VAR26,-0,-5,5,1 ) COLORRED LINETHICK4;
STICKLINE(VAR25<VAR26,-0 ,-5,5,1 ) COLORGREEN LINETHICK4;
20,POINTDOT;
50,POINTDOT;
80,POINTDOT;

通达信波段循环指标公式

 

相关文章