在线检测未来函数

通达信八字KDJ指标公式

来源:Internet,编辑:股旁网,2013-09-20

D:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,20);
J:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5);
BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
八字KDJ4:EMA(D,3),COLOR00FF00,LINETHICK2;
M:EMA(J,7),COLORWHITE,LINETHICK2;
八字KDJ: ((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)
-50)*1.032+50),COLORRED,LINETHICK2;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(买线>=卖线,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),
COLORWHITE;
STICKLINE(买线<卖线,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),
COLORYELLOW;
VAR1:=1;
VAR2:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR3:=LLV(LOW,34);
VAR4:=HHV(HIGH,34);
RR:=EMA(EMA(CLOSE,9),9);
控盘:=(RR-REF(RR,1))/REF(RR,1)*1000;
A10:=CROSS(控盘,0);
买两股:IF(A10,50,0),LINETHICK1,COLORYELLOW;
AR1:=PEAKBARS(3,15,1)<10;
AR2:=IF(AR1=1,2,0);
顶:= IF(AR2=2,2,0);
卖出好:IF(顶>REF(顶,1),50,0),COLORWHITE;
DRAWTEXT(卖出好=45,50,'快走'),COLORRED;
买: (ZIG(3,35)>REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)<REF(ZIG(3,35),2))
*50,STICK,COLORMAGENTA,LINETHICK3;
卖: (ZIG(3,35)<REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)>REF(ZIG(3,35),2))
*50,STICK,COLORLIBLUE,LINETHICK3;
VAR21:=MA(CLOSE,80)-(MA(CLOSE,13))/(3);
VAR22:=MA((CLOSE-VAR21)/(VAR21),1);
VAR23:=(EMA(VAR22,12))*(0.69999998);
VAR24:=EMA(VAR22,3);
VAR25:=IF((LLV(VAR24-VAR23,12)>0),0,(-30));
VAR26:=FILTER((COUNT((VAR25<(-20)),3)=3),34);
快全买:IF(VAR26,50,0),COLORLICYAN;
顶线:100,COLORRED;
底线:0,COLORGREEN;

通达信八字KDJ指标公式

 

相关文章