在线检测未来函数

通达信乾坤K线主图指标公式

来源:Internet,编辑:股旁网,2013-09-29

SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,
(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
量能饱和度:SAT,COLORYELLOW,NODRAW;
AA10:=MA(CLOSE,8),COLOR0000FF;
AA12:=MA(CLOSE,12),COLOR0000FF;
BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);
MA13:=MA(CLOSE,13);
DRAWBAND(AA10,RGB(180,0,0),AA12,RGB(0,158,0));
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45上升'),COLORWHITE;
多头:MA(CLOSE,8),COLORFF59FF;
空头:MA(CLOSE,12),COLOR00FF00;
压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.99),'老鼠仓'),COLOR4080FF;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2
*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,(HIGH* 0.97),'▲大黑马'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'顶背离'),COLOR1880FF;
VAR2:=LLV(LOW,27);
VAR3:=HHV(HIGH,34);
VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;
注意买:=IF((VAR4<10),80,100);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
超跌:=IF(J<0,10,0);
BDDD:=LLV(J,2)=LLV(J,8);
买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0);
DRAWTEXT(买入 AND 注意买=100 AND 超跌=0,LOW,'短线'),COLOR8000FF;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买=1,5),LOW-0.05,'↖拉升'),COLORFFDE00;
{STICKLINE(CLOSE>OPEN,OPEN,LOW,0,1 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0,1 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0,1 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0,1 ),COLOR00FF00;}
{3D天蓝}
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.7,0 ),COLORFF7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2.3,0 ),COLORFF9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1.8,0 ),COLORFFBB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1.3,0 ),COLORFFCC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.8,0 ),COLORFFDD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.3,0 ),COLORFFEE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.1,0 ),COLORFFFF00;
{3D枣红}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.7,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.3,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.8,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.3,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.8,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.3,0) ,COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.1,0) ,COLOR0000FF;
VAR9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3))
OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4)
AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4)
AND C>=REF(C,1) AND C>=REF(C,2);
STICKLINE(VAR9Q,C,(O+C)/2,2.7,0),COLOR000055;
STICKLINE(VAR9Q,C,(O+C)/2,2.3,0),COLOR000066;
STICKLINE(VAR9Q,C,(O+C)/2,1.8,0),COLOR000077;
STICKLINE(VAR9Q,C,(O+C)/2,1.3,0),COLOR000099;
STICKLINE(VAR9Q,C,(O+C)/2,0.8,0),COLOR0000BB;
STICKLINE(VAR9Q,C,(O+C)/2,0.3,0),COLOR0000DD;
STICKLINE(VAR9Q,C,(O+C)/2,0.1,0),COLOR0000FF;
VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
{3D粉红色}
STICKLINE(VARAQ,C,(O+C)/2,2.7,0),COLORFF11FF;
STICKLINE(VARAQ,C,(O+C)/2,2.3,0),COLORFF33FF;
STICKLINE(VARAQ,C,(O+C)/2,1.8,0),COLORFF55FF;
STICKLINE(VARAQ,C,(O+C)/2,1.3,0),COLORFF77FF;
STICKLINE(VARAQ,C,(O+C)/2,0.9,0),COLORFF99FF;
STICKLINE(VARAQ,C,(O+C)/2,0.3,0),COLORFFBBFF;
STICKLINE(VARAQ,C,(O+C)/2,0.1,0),COLORFFDDFF;
VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3))
OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4)
AND REF(C,1)!=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4)
AND C<REF(C,1) AND C<REF(C,2);
{3D银灰色}
STICKLINE(VARBQ,C,(O+C)/2,2.7,0),COLOR333333;
STICKLINE(VARBQ,C,(O+C)/2,2.3,0),COLOR555555;
STICKLINE(VARBQ,C,(O+C)/2,1.8,0),COLOR777777;
STICKLINE(VARBQ,C,(O+C)/2,1.3,0),COLOR999999;
STICKLINE(VARBQ,C,(O+C)/2,0.8,0),COLORBBBBBB;
STICKLINE(VARBQ,C,(O+C)/2,0.3,0),COLORDDDDDD;
STICKLINE(VARBQ,C,(O+C)/2,0.1,0),COLORFFFFFF;
VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4)
AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
STICKLINE(VARCQ,O,(O+C)/2,2.3,0),COLOR003300;
{ STICKLINE(VARCQ,O,(O+C)/2,2.7,0),COLOR00AAAA;
STICKLINE(VARCQ,O,(O+C)/2,1.5,0),COLOR00CCCC;
STICKLINE(VARCQ,O,(O+C)/2,0.5,0),COLOR00FFFF;};

通达信乾坤K线主图指标公式

 

相关文章