在线检测未来函数

通达信追牛至顶主图指标公式

来源:Internet,编辑:股旁网,2013-09-02

用法: “多”与“空”代表双方力量的变化,当下降后“多”>“空”可考虑买入。 “操作”线由下降变走平,拐头向上后股价站于其上后再买入,“波段牛熊”线同上。 当股价站在“长期牛熊”之上方可认为该股进入“牛市”上升期。 图中“B”=买入,“S”=卖出,“p”=加仓,“m”=减仓。

a:=(3*c+l+o+h)/6;
b:=(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+ref(a,20))/210;
多:ma(b,2),colorred;
空:ma(b,3),colorblue;
操作:ma(b,13),coloryellow;
波段牛熊:ma(b,34),colorgreen;
长期牛熊:ma(b,233),colorwhite;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=cross(买线,卖线);
SEL:=cross(卖线,买线);
drawtext(bu,LOW*0.999,'B'),colorred,linethick3;
DRAWTEXT(bu,LOW,'﹉'),Color208FFF,LINETHICK3;
DRAWTEXT(sel,HIGH,'﹉'),ColorFFFF00,LINETHICK3;
drawtext(sel,HIGH*1.02,'S'),colorffff00,linethick3;
stickline(买线>=卖线,low,high,1,0),colorred;
stickline(买线>=卖线,close,open,4.5,0),color0000aa;
stickline(买线>=卖线,close,open,4,0),color0000cc;
stickline(买线>=卖线,close,open,3,0),color0000cc;
stickline(买线>=卖线,close,open,2,0),color0000ee;
stickline(买线<卖线,close,open,4.5,0),coloraaaa00;
stickline(买线<卖线,close,open,4,0),colorbbbb00;
stickline(买线<卖线,close,open,3,0),colorcccc00;
stickline(买线<卖线,close,open,2,0),coloreeee00;
stickline(买线<卖线,low,high,1,0),colorffff00;
stickline(cross(买线,卖线) or cross(卖线,买线),open,close,3,0),color00ffff;
指导线:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),linethick1,ColorFFffFF;
界:=MA(CLOSE,27),linethick1,Color00FFFF;
DRAWTEXT(cross(指导线,界),界,' ̄'),Colorffffff;
DRAWTEXT(cross(界,指导线),界,' ̄'),Color00ffff;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
G:=95;
DRAWTEXT(cross(J,D),L*0.999,'p'),Color00ffff,linethick4;
DRAWTEXT(cross(J,D),L,' ̄'),Color00ffff;
DRAWTEXT(cross(J,G),H*1.02,'m'),Colorffff00,linethick4;
DRAWTEXT(cross(J,G),H,' ̄'),Colorffff00;

通达信追牛至顶主图指标公式

 

相关文章