在线检测未来函数

通达信庄见血滴指标公式

来源:Internet,编辑:股旁网,2013-10-10

QQ_1:=C-REF(C,1);
QQ_2:=100*EMA(EMA(QQ_1,6),6)/EMA(EMA(ABS(QQ_1),6),6);
QQ_3:=CROSS(EMA(C,19),EMA(C,7));
QQ_4:=CROSS(EMA(C,7),EMA(C,19));
ZZ1:=L=LLV(L,BARSLAST(QQ_3)+1);
ZZ2:=LLV(L,BARSLAST(QQ_3)+1);
ZZ3:=H=HHV(H,BARSLAST(QQ_4)+1);
ZZ4:=HHV(H,BARSLAST(QQ_4)+1);
QQ_A:=DRAWLINE(ZZ1,ZZ2,ZZ3,ZZ4,0);
YY1:=H=HHV(H,BARSLAST(QQ_4)+1);
YY2:=HHV(H,BARSLAST(QQ_4)+1);
YY3:=L=LLV(L,BARSLAST(QQ_3)+1);
YY4:=LLV(L,BARSLAST(QQ_3)+1);
QQ_B:=DRAWLINE(YY1,YY2,YY3,YY4,0);
TTJ:=IF(QQ_B<REF(QQ_B,1) AND QQ_B=QQ_A,1,0);
一绝:STICKLINE(REF(TTJ,1)=0 AND TTJ>=1 AND CCI<-40 ,0,90,1,-1),COLORRED;
VAR1A:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2A:=SMA(ABS(LOW-VAR1A),13,1)/SMA(MAX(LOW-VAR1A,0),10,1);
VAR3A:=EMA(VAR2A,10);
VAR4A:=LLV(LOW,33);
VAR5A:=EMA(IF(LOW<=VAR4A,VAR3A,0),3);
洗盘:=IF(VAR5A<REF(VAR5A,1),VAR5A,0),COLORRED,LINETHICK0;
STICKLINE(VAR5A<REF(VAR5A,1),0,VAR5A/2,3.5,0),COLORLIBLUE;
STICKLINE(VAR5A<REF(VAR5A,1),0,VAR5A/2,0.5,0),COLORRED;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13
OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
短进:=VAR19;
N7:=7;
VAR1AA:=REF(C,1);
VAR2AA:=SMA(MAX(C-VAR1AA,0),N7,1)/SMA(ABS(C-VAR1AA),N7,1)*1000;
VAR3AA:=DRAWLINE(VAR2AA>=HHV(VAR2AA,N7),VAR2AA,VAR2AA<=LLV(VAR2AA,N7),VAR2AA,1);
VAR4AA:=VAR2AA=VAR3AA;
VAR5AA:=VAR2AA<REF(VAR2AA,1);
PD1:=VAR4AA AND VAR5AA;
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0);
Y1:=H=HHV(H,BARSLAST(Q_4)+1);
Y2:=HHV(H,BARSLAST(Q_4)+1);
Y3:=L=LLV(L,BARSLAST(Q_3)+1);
Y4:=LLV(L,BARSLAST(Q_3)+1);
Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0);
TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);
JDMD:=REF(TJ,1)=0 AND TJ>=1;
PD11:=PD1 AND JDMD;
PD7:=IF(PD1,SUM(JDMD,3),0);
PD8:=IF(PD7>0,0,1);
PD9:=PD1 AND PD8;
PD3:=IF(JDMD,SUM(PD1,3),0);
PD4:=IF(PD3>0,0,1);
PD5:=JDMD AND PD4;
PD6:=FILTER(IF(PD11,1,PD9 OR PD5),2);
抄底:PD6,NODRAW,COLOR00FFFF;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:CEILING(SMA(AA5,13,8)),COLORRED,LINETHICK1;
STICKLINE(JDMD,走势,走势+45,2,0),COLOR00FFFF;
卖吧:IF(PEAKBARS(3,15,1)=1,51,120),COLORGREEN,LINETHICK1;
DRAWTEXT(卖吧=51,100,'卖吧');
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
MMM:=IF(VAR8Q>100,100,VAR8Q);
STICKLINE(MMM>0 AND MMM>REF(MMM,1),0 ,MMM,3.5,0 ),COLOR4444FF;
STICKLINE(MMM>0 AND MMM>REF(MMM,1),0 ,MMM,0.5,0 ),COLOR9999FF;
VARA1A:=EMA(EMA(CLOSE,13),13);
控盘:=(VARA1A-REF(VARA1A,1))/REF(VARA1A,1)*1000;
JJ:=DYNAINFO(11);
P:=55;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
BTJ1:=(C-JJ)/JJ<-0.03;
BTJ11:=(C-JJ)/JJ<-0.03;
STJ02:=控盘>0;

通达信庄见血滴指标公式

 

相关文章