在线检测未来函数

通达信抓牛拐点指标公式

来源:Internet,编辑:股旁网,2013-10-24

DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
DRAWTEXT_FIX(1,0.88,5,0,'~☆~隆逸优化作品~☆~'),COLORRED;
N:=5;
P1:=80;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3,POINTDOT;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3,POINTDOT;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
异动:=CROSS(V2,REF(V2,1)*1.2) AND LONGCROSS(CLOSE,REF(C,1)*1.025,4) AND V/REF(MA(V,5),1)>2,COLORMAGENTA;
抓牛:C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND REF(MACD,1)<MACD ,COLORYELLOW,LINETHICK3;
GD:=DY2<REF(DY2,1) AND REF(DY2,1)<REF(DY2,2) AND REF(DY2,2)<REF(DY2,3) AND C>O AND VAR3>VAR5 AND C/REF(C,1)>=1.02;
GD2:=DY2<REF(DY2,1) AND REF(DY2,1)<REF(DY2,2) AND REF(DY2,2)<REF(DY2,3)AND VAR3>VAR5;
DRAWTEXT(CROSS(V2,REF(V2,1)*1.2) AND LONGCROSS(CLOSE,REF(C,1)*1.025,4) AND DDX/REF(MA(DDX,5),1)>2,0,'★'),COLORMAGENTA;
MACD:="MACD.MACD",NODRAW;
拐点:CROSS(C,VAR2) AND CROSS(C,VAR6) AND MACD<0 AND REF(MACD,1)<MACD ,COLORMAGENTA,LINETHICK3;
STICKLINE(抓牛=1,0,8,2,0),COLORYELLOW;
DRAWTEXT(抓牛=1,5,' 抓牛'),COLORYELLOW;
STICKLINE(拐点=1,0,8,2,0),COLORMAGENTA;
DRAWTEXT(拐点=1,4,' 拐点'),COLORMAGENTA;

通达信抓牛拐点指标公式

 

相关文章