在线检测未来函数

通达信RSI通道指标公式

来源:Internet,编辑:股旁网,2013-12-04

使用方法: 1、设置好一条均线20; 2、发出信号时,股价要突破20均线; 3、K线的形态是从20均线下方,向上突破20线;

N1:=14;
N2:=25;
P:=36;
LC:= REF(CLOSE,1);
RSI6:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLOR000000,LINETHICK0;
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORFFFFFF;
RSI2:=SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100;
{IF((RSI1>RSI2)AND(RSI1>=50),RSI1,DRAWNULL),COLORGREEN;
IF(RSI1<30,RSI1,DRAWNULL),COLORRED;}
MID:=EMA(RSI1,P);
上轨:MID + 2*STD(RSI1,20),COLOR993300;
下轨:MID - 2*STD(RSI1,20),COLORFF00FF;
中轨:((上轨-下轨)/2)+下轨,COLORFFFFFF,POINTDOT,LINETHICK2;
BIAS:=(CLOSE-MA(CLOSE,25))/MA(CLOSE,25)*100;
IF(RSI6<20,20,15),COLOR336699;
IF(RSI6<10,28,15),COLORFF9900;
IF(RSI6<20 AND BIAS<-3.5,20,15),COLORAAAAAA;
IF(RSI6<20 AND BIAS<-3.5 AND (L*1.05)<=EMA(C,25),20,15),COLORRED;
IF(REF(RSI6,1)>76 AND RSI6<76,65,85),COLOR006633;
IF(RSI6>75 AND BIAS>3.5,77,85),COLOR0099CC;
VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
短顶:STICKLINE(VAR1>9 AND FILTER(VAR1<REF(VAR1,1),5),中轨*1.1,中轨,1,0),COLORGREEN;
大顶:STICKLINE(VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),中轨*1.1,中轨,1,0),COLOR00FF00;
VAR2:=HHV(VAR1>20,10);
危险:STICKLINE(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),中轨*1.1,中轨,4,0);
注意止损:STICKLINE(VAR2 AND FILTER(VAR1< REF(VAR1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),上轨,中轨,3,0);
短底:STICKLINE(VAR1<-9 AND VAR1> REF(VAR1,1),中轨*0.9,中轨,1,0),COLORRED;
大底:STICKLINE(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),下轨,中轨,1,0),COLORYELLOW;
买入准备:=VAR1<-9 AND VAR1>REF(VAR1,1),COLORWHITE;
DRAWTEXT(VAR1>9 AND FILTER(VAR1<REF(VAR1,1),5),RSI-5,'短顶'),COLOR00FF00;
DRAWTEXT(VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),RSI-5,'大顶'),COLORFFFF00;
DRAWTEXT(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),RSI-5,'危险'),COLOR00FFFF;
DRAWTEXT(VAR2 AND FILTER(VAR1< REF(VAR1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),RSI-5,'注意止损'),COLORFF00FF;
DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18),下轨,'短底'),,COLOR0000FF;
DRAWTEXT(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),下轨,'大底'),;
DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18),下轨-5,'买入准备');
R6:RSI6,COLOR000033,LINETHICK1;

通达信RSI通道指标公式

 

相关文章