在线检测未来函数

通达信超级资金选股指标公式

来源:Internet,编辑:股旁网,2013-12-20

涨幅:=9;高度:=20;跨度:=10;N4:=34;
短线:=EMA(CLOSE,17);
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线:=EMA(KKC,50);
中期:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
KDD:=REF(中期,1)<1 AND 中期>1;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA
((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
支撑:=LLV(持股,3);
中期线:=MA(持股,12);
VAR1:=1;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
短期线:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1*30;
AAA:=(3*C+L+O+H)/6;
C2:=EMA(AAA,6);
C3:=EMA(AAA,5);
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
KAAA1:=EXIST(KDD,3);
KBBB1:=C/REF(C,1)>1+0.01*涨幅;
KAAA2:=支撑>中期线 AND 持股=支撑;
KBBB2:=CROSS(C2,C3);
KCCC2:=EXIST(C/REF(C,1)>1+0.01*涨幅,跨度);
KDDD2:=BARSLAST(中期线>短期线)<跨度;
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*涨幅;
KCCC3:=中线/长线<1+0.01*高度;
超资: IF(KBBB1+KCCC2+KBBB3=3,1,0);

通达信超级资金选股指标公式

 

相关文章