在线检测未来函数

通达信短线操盘2主图指标公式

来源:Internet,编辑:股旁网,2014-01-26

MA5:=MA(C,5),COLORWHITE;
MA10:=MA(CLOSE,10),COLORYELLOW;
MA30:=MA(C,30),COLORMAGENTA,LINETHICK3;
MA60:=MA(CLOSE,60),COLORFFCC66;
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
BAIJIN1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
BAIJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
BAIJIN3:=GJTJ1>60 AND GJTJ4>70;
DRAWTEXT(BAIJIN1 AND BAIJIN2 AND BAIJIN3,L-0.02,'白金'),COLORWHITE;
HUANGJIN1:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
HUANGJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
DRAWTEXT(HUANGJIN1 AND HUANGJIN2,L-0.03,'黄金'),COLORYELLOW;
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5 AND GJTJ1>GJTJ4;
DRAWTEXT(COUNT(XG,3)=1 AND XG AND C>MA(C,20),L-0.02,'启动金三角'),COLORRED;
ZHENCANG1:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG2:=BARSLAST(CROSS(GJTJ4,GJTJ2));
ZHENCANG3:=GJTJ3<GJTJ4 AND GJTJ2<GJTJ4;
ZHENCANG4:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG5:=GJTJ2<GJTJ3 AND GJTJ2<GJTJ4 AND GJTJ2<GJTJ1 AND GJTJ1=100;
ZCB1:=ZHENCANG1>0 AND REF(ZHENCANG1,1)=0 AND REF(ZHENCANG1,2)>0;
DRAWTEXT(ZHENCANG1 AND ZHENCANG2 AND ZHENCANG3 AND ZHENCANG4 AND ZHENCANG5,L-0.05,'震仓启点');
AAB:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BB:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA1:=AAB AND BB;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA2:=AAB AND BB ;
AAAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA3:=AAAA AND BAAA ;
BB1:=REF(AA1,1);
BB2:=REF(AA2,1);
BB3:=REF(AA3,1);
DD1:=GJTJ1=100 AND GJTJ2=100 AND AA1 ;
DD2:=GJTJ1=100 AND GJTJ2=100 AND AA2 ;
DD3:=GJTJ1=100 AND GJTJ2=100 AND AA3 ;
DRAWTEXT(DD1 OR DD2 OR DD3,L-0.02,'短追'),COLORFF00FF;
AW:=BARSLAST(CROSS(95,GJTJ1))<=2;
BW:=BARSLAST(CROSS(95,GJTJ2))<=2;
EW:= GJTJ4<GJTJ1 AND GJTJ1<GJTJ2 AND GJTJ1<GJTJ3;
FW:=GJTJ2>50 AND GJTJ3>50;
GW:=GJTJ1=100 AND GJTJ2=100;
TXW:=COUNT(GW,2)=1;
DRAWTEXT(AW AND BW AND EW AND FW AND TXW,L-0.03,'起涨首日');
AQ:=GJTJ3=100;
BQ:=GJTJ4<90;
DRAWTEXT(COUNT(AQ,2) = 2 AND BQ,L-1.08,'波启前兆');
{超级资金}
{机构买入:L2_AMO(0,2)/10000.0,NODRAW;}
{机构卖出:-L2_AMO(0,3)/10000.0,NODRAW;
机构净买:机构买入+机构卖出,NODRAW;}
{K线画半截颜色资金动向标示}
{逐笔大单DDE}
大单动向:(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7),NODRAW;{逐笔买入大单成交-逐笔卖出大单成交)*10000/流通股本(股}
A01:=MIN(O,C);
B01:=ABS(O-C);
STICKLINE(大单动向>0,A01,A01+B01/3.5,2,0),COLORRED;
STICKLINE(大单动向>0,A01,A01+B01/3.5,2,0),COLORRED;
STICKLINE(大单动向>0,A01,A01+B01/3.5 ,3.2,0) ,COLOR000066;
STICKLINE(大单动向>0,A01,A01+B01/3.5 ,2.7,0) ,COLOR000099;
STICKLINE(大单动向>0,A01,A01+B01/3.5,2.1,0) ,COLOR0000AA;
STICKLINE(大单动向>0,A01,A01+B01/3.5 ,1.8,0) ,COLOR0000DD;
STICKLINE(大单动向>0,A01,A01+B01/3.5 ,0.8,0) ,COLOR0000FF;
STICKLINE(大单动向>0,A01,A01+B01/3.5 ,0,0) ,COLORCC66FF;
STICKLINE(大单动向<0,A01+B01,A01+B01/1.8,2.2,0),COLOR00AA00;
STICKLINE(大单动向<0,A01+B01,A01+B01/1.8,3.2,0 ),COLOR005500;
STICKLINE(大单动向<0,A01+B01,A01+B01/1.8 ,2.7,0 ),COLOR007700;
STICKLINE(大单动向<0,A01+B01,A01+B01/1.8 ,2.1,0 ),COLOR009900;
STICKLINE(大单动向<0,A01+B01,A01+B01/1.8 ,1.8,0 ),COLOR00AA00;
STICKLINE(大单动向<0,A01+B01,A01+B01/1.8 ,0.9,0 ),COLOR00CC00;
STICKLINE(大单动向<0,A01+B01,A01+B01/1.8 ,0,0 ),COLOR00FF00;
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
DRAWICON(TJ,HIGH*1.01+0.02,2);
警告灯:IF(TJ,HIGH*1.008,DRAWNULL),CROSSDOT,LINETHICK2,COLORCYAN;
PL:=BARSLAST(TJ);
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORGRAY,LINETHICK2;
TJ_2:=LOW>REF(REF(LOW,TS),PL);
DRAWTEXT(ISLASTBAR,压力,'压力'),COLORYELLOW;
A11:=EMA(C,14)COLORWHITE,LINETHICK1;
A1X:=(A11-REF(A11,1))/REF(A11,1)*100,NODRAW;
看多做多:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL),COLORCYAN,LINETHICK1;
DRAWTEXT(ISLASTBAR,看多做多*1.001,' 看多做多'),COLORC0C0C0,LINETHICK1;
AA17:=EMA(C,14)COLORWHITE,LINETHICK1;
A17X:=(AA17-REF(AA17,1))/REF(AA17,1)*100,NODRAW;
试买:IF(A17X>=0,REF(EMA(C,14),BARSLAST(CROSS(A17X,0))+1),DRAWNULL)COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,试买,' 试买'),COLORYELLOW,LINETHICK4;
{变色K线}
N1:=14;
M:=6;
TR1:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N1);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N1);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N1);
PDI:=DMP*100/TR1,LINETHICK2;
MDI:=DMM*100/TR1;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,H,L,0,0),COLOR0000FF;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLOR0000FF;
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,L,H,0,0),COLORC08000;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORC08000;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORMAGENTA ;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORMAGENTA ;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORMAGENTA ;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0) ,COLOR00FF00; };
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2))COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3))COLOR00FFFF;
DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLOR0080FF;
DRAWTEXT_FIX (1,0.43,0.15,0,'收益:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLOR0080FF;
DRAWTEXT_FIX(1,0.00,0.19,0,'净流(亿):'),COLORYELLOW;
DRAWTEXT_FIX(1,0.06,0.19,0,'1日'),COLORYELLOW;
DRAWTEXT_FIX(1,0.12,0.19,0,'3日'),COLORYELLOW;
DRAWTEXT_FIX(1,0.18,0.19,0,'5日'),COLORYELLOW;
DRAWTEXT_FIX(1,0.24,0.19,0,'10日'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.08,0.19,0,CONST((净流))),COLOR0080FF;
DRAWNUMBER_FIX(1,0.14,0.19,0,CONST((净流3))),COLOR0080FF;
DRAWNUMBER_FIX(1,0.20,0.19,0,CONST((净流5))),COLOR0080FF;
DRAWNUMBER_FIX(1,0.265,0.19,0,CONST((净流10))),COLOR0080FF;
DRAWTEXT_FIX(1,0.00,0.27,0,'愚民导向:'),COLOR00FFFF;
DRAWTEXT_FIX(1,0.06,0.27,0,EXTERNSTR(0,5)),COLOR00FFFF;
日:=50;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H0:=高1-(高1-低1)*0.632;
H5:=高1-(高1-低1)*0.809;
L1:=低1+(高1-低1)*1.191;
L2:=低1+(高1-低1)*1.382;
L3:=低1+(高1-低1)*1.5;
L4:=低1+(高1-低1)*1.618;
L0:=低1+(高1-低1)*1.632;
L5:=低1+(高1-低1)*1.809;
短压:REFDATE(高1,DATE),COLORGREEN,LINETHICK1;
支撑19.1%:REFDATE(H1,DATE),COLORYELLOW;
支撑38.2%:REFDATE(H2,DATE),COLORMAGENTA;
支撑50%:REFDATE(H3,DATE),COLORLIGRAY;
支撑61.8%:REFDATE(H4,DATE),COLORWHITE,LINETHICK1;
支撑63.2%:REFDATE(H0,DATE),COLORRED,LINETHICK1;
支撑80.9%:REFDATE(H5,DATE),COLORWHITE;
低:REFDATE(低1,DATE),COLORWHITE;
阻力119.1%:REFDATE(L1,DATE),COLORYELLOW;
阻力138.2%:REFDATE(L2,DATE),COLORMAGENTA;
阻力150%:REFDATE(L3,DATE),COLORLIGRAY;
阻力161.8%:REFDATE(L4,DATE),,COLORLIGRAY;
阻力163.2%:REFDATE(L0,DATE),COLORRED;
阻力180.9%:REFDATE(L5,DATE),COLORWHITE;
{提示}
DRAWTEXT(ISLASTBAR,短压,'短压'),COLORWHITE;
STICKLINE(CURRBARSCOUNT=1,低,低,1000,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=1,短压,短压,1000,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,支撑19.1%,支撑19.1%,1000,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=1,支撑38.2%,支撑38.2%,1000,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=1,支撑50%,支撑50%,1000,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=1,支撑61.8%,支撑61.8%,1000,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=1,支撑80.9%,支撑80.9%,1000,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT=1,阻力119.1%,阻力119.1%,1000,-1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=1,支撑63.2%,支撑63.2%,1000,-1),COLORRED;
{过线放量买}
T1B:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T1B));
CCC:=CONST(CURRBARSCOUNT);
T2B:=CONST(BARSLAST(CURRBARSCOUNT>CCC+T1B AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T2B));
T3B:=CONST(BARSLAST(CURRBARSCOUNT>CCC+T2B AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T3B));
抢钱10:DRAWLINE(CURRBARSCOUNT=T3B+1, T3HIGH, ISLASTBAR, T3HIGH, 1),COLORYELLOW,LINETHICK2;{,LINETHICK2,COLOR0000FF;}
DRAWTEXT(ISLASTBAR, T3HIGH, '抢钱10')LINETHICK1,COLORYELLOW;
{AAAA:抢钱10,COLORYELLOW,LINETHICK1;}
DRAWNUMBER(抢钱10!=REF(抢钱10,1),H,抢钱10),COLORYELLOW;
HLCO:=(C+H+L+O)/4;
MAHC:=MA((CLOSE*2+H)/3,5),COLOR0000FF;
MAHO:=MA((O*2+H)/3,5),COLOR00FF00;
MALC:=MA((C+L*2)/3,5),COLORFFFFFF;
MALO:=MA((O+L*2)/3,5),COLOR00FFFF;
CO:=O+(C-O)/2;
LC:=REF(CLOSE,1);
STICKLINE(MAHC<MAHO AND (CROSS(C,MALO) OR CROSS(HLCO,MALO)),C,O,2.8,0),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.12,0,'--------------------白K关注,黄K买入');
白色:= SMA(HIGH,21,2)*1.05,COLORWHITE;
突破1:=REF(EMA(C,14),1);
下轨:=SMA(LOW,21,2)*0.95,CIRCLEDOT,COLORFF6600;
SQS:=IF(MA(VOL,3)>MA(VOL,5)>MA(VOL,9),SMA(CLOSE,3,1),SMA(CLOSE,5,1)),COLORFF99FF,LINETHICK3;
做:=CROSS(SQS,突破1);
STICKLINE( 做=1,LOW,HIGH,0,0),COLORWHITE;
STICKLINE( 做=1,CLOSE,OPEN,3,0),COLORWHITE;
DRAWTEXT(CROSS(SQS,突破1) AND 白色>REF(白色,1),下轨,'加买'),COLORWHITE;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,3.15,0),COLOR337777;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,2.45,0),COLOR339999;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.75,0),COLOR33BBBB;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,1.05,0),COLOR33DDDD;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L,OPEN,0.35,0),COLOR33FFFF;
DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),L*0.99,'地量买点'),COLOR33FFFF;
网33:EXPMA(CLOSE,33),COLORFF00FF,LINETHICK4;

通达信短线操盘2主图指标公式

 

相关文章