在线检测未来函数

通达信天地指标公式

来源:Internet,编辑:股旁网,2014-02-24

STICKLINE(C>0,0,100,15,0),COLOR7C221C;
VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
波:=VAR3;
段:=VAR4;
VAR5:=CROSS(VAR3,VAR4) AND VAR3<20;
DRAWTEXT(FILTER(VAR5,10)=1,40,'底'),COLORRED;
STICKLINE(FILTER(VAR5,10)=1,0,20,10,0),COLORRED;
VAR9:=CROSS(VAR4,VAR3) AND VAR3>80;
STICKLINE(FILTER(VAR9,5)=1,80,100,4,0),COLOR007700;
STICKLINE(FILTER(VAR9,5)=1,80,100,3,0),COLOR009900;
STICKLINE(FILTER(VAR9,5)=1,80,100,2,0),COLOR00BB00;
STICKLINE(FILTER(VAR9,5)=1,80,100,1,0),COLOR00DD00;
STICKLINE(FILTER(VAR9,5)=1,80,100,0.3,0),COLOR00FF00;
DRAWTEXT(FILTER(VAR9,5)=1,70,'顶'),COLORGREEN;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
STICKLINE(VAR8,85,100,10,0),COLOR0099FF;
100,COLORBBBBBB,LINETHICK3;
0,LINETHICK3;
AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
云:80,COLORWHITE;
天:87.5,COLORBLUE,LINETHICK3;
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
飞:=DD,COLOR00FFFF,LINETHICK2;
{IF(DD>REF(DD,1),DD,DRAWNULL),COLORRED,LINETHICK2;
IF(DD<REF(DD,1) AND DD<87.5,DD,DRAWNULL),COLOR00FF00,LINETHICK2;}
海:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
买B:=IF(CROSS(海,90) AND (飞<40),30,0),COLORYELLOW,LINETHICK2;
地:10,COLORGREEN,LINETHICK3;
买A:IF((COUNT((飞>REF(飞,1)),1)=1) AND (REF(飞,1)<REF(REF(飞,1),1))
AND (飞<地),40,0),COLORRED,LINETHICK2;
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,30,0,4,0),COLOR770077;
STICKLINE(A1,30,0,3,0),COLOR990099;
STICKLINE(A1,30,0,2,0),COLORBB00BB;
STICKLINE(A1,30,0,1,0),COLORDD00DD;
STICKLINE(A1,30,0,0.3,0),COLORFF00FF;
DRAWTEXT(A1,36,'全仓'),COLORRED;
持股:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-
LLV(LOW,27))*100,5,1),3,1),LINETHICK,COLORRED;
支撑:LLV(持股,3),LINETHICK,COLOR00FFFF;
下跌:MA(持股,12),COLOR6B8E23,LINETHICK2;
转向:=CROSS(持股,下跌) AND 下跌<30;
MA1:=MA(持股,5);
VAR18:=CROSS(MA1,持股) AND MA1>80;
{STICKLINE(支撑<下跌,支撑,下跌,2,0),COLOR6B8E23;}
DRAWBAND(支撑,RGB(238,0,6),下跌,RGB(256,250,60));
{STICKLINE(持股>0,支撑,持股,2,0),COLORRED;}
DRAWBAND(持股,RGB(238,0,6),支撑,RGB(256,150,60));
STICKLINE(支撑>下跌,下跌,支撑,2,0),COLOR38B0DE;
DRAWICON(转向,支撑*0.98,23);
DRAWICON(VAR18,持股*1.03,15);

通达信天地指标公式

 

相关文章