在线检测未来函数

飞狐保护神指标公式

来源:Internet,编辑:股旁网,2014-03-07

DRAWGBK(CLOSE,COLORRGB(36,68,36),COLORRGB(100,100,100),1);
XDJ1:=LLV(LOW,13);
XDJ2:=EMA(((3*CLOSE+HIGH+LOW+OPEN)/6-XDJ1)/(HHV(HIGH,13)-XDJ1),8);
XDJ3:=EMA(XDJ2,2)*100;
CD1:=REF(CLOSE,1)/CLOSE;
CD2:=(1-MA(LOW,3)/(MA((HIGH+LOW+2*CLOSE)/4,20)))*100-5;
CD3:=(MA(HIGH,3)/(MA((HIGH+LOW+2*CLOSE)/4,20))-1)*100-5;
CD4:=IF(CD2>0,CD2*(REF((HIGH+LOW+2*CLOSE)/4,3))/CLOSE,0);
HZ1:=MA(LOW,2)*0.96;
HZ2:=MA(LOW,26)*0.85;
HZ3:=IF(REF(HZ1,1)<HZ2 AND REF(HZ1,1)<HZ1 AND REF(HZ1,1)<REF(HZ1,2),8,0);
铁底:=MA(LOW,30)*0.85;
N1:=SYSPARAM(3);
N2:=SYSPARAM(2);
N3:=N1-N2+1;
HH:=HHV(XDJ3,N3);
LL:=LLV(XDJ3,N3);
高:=HH[N1]*0.9;
中:=(HH[N1]+LL[N1])/2;
低:=LL[N1]*1.3;
最低:=LL[N1];
Y:=HHV(VOL,N1-N2+1);
YVB:=Y[N1]/(HH[N1]-LL[N1]+MINDIFF);
Z:=VOL/YVB+LL[N1];
Z_1:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100-50;
Z_2:=SMA(Z_1,3,1);
Z_3:=EMA(3*Z_2-2*SMA(Z_2,3,1),6);
Z_4:=(Z_3-REF(Z_3,1))*3;
ZJ1:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
ZJ2:=VOL/((HIGH-LOW)*2-(ABS(CLOSE-OPEN)));
ZJ3:=(IF(CLOSE>OPEN,ZJ2*(HIGH-LOW),IF(CLOSE<OPEN,ZJ2*(HIGH-OPEN+CLOSE-LOW),VOL/2)))+(IF(CLOSE>OPEN,-ZJ2*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,-ZJ2*(HIGH-LOW),-VOL/2)));
ZJ4:=ZJ3/20/1.15;
ZJ5:=ZJ4*0.55+REF(ZJ4,1)*0.33+REF(ZJ4,2)*0.22;
ZJ6:=EMA(ZJ5,3);
QJ1:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5));
QJ2:=(SMA(MAX(QJ1-REF(QJ1,1),0),8,1))/(SMA(ABS(QJ1-REF(QJ1,1)),8,1));
QJ3:=EMA(QJ2,5)-EMA(QJ2,13);
QJ4:=(QJ3-LLV(QJ3,3))/(HHV(QJ3,3)-LLV(QJ3,3));
QJ5:=SMA(QJ4,3,1)/3;
QJ6:=SMA(QJ5,3,1);
KK:=(3*QJ5-2*QJ6)*2.5;
DD:=EMA((3*QJ5-2*QJ6)*2.5,3);
T1:=BARSLAST(CROSS(DD,KK));
T2:=BARSLAST(KK>DD);
B:=DATACOUNT-BARPOS+1;
SJ:=DATACOUNT-SYSPARAM(1);
FC:=VOL;
FOR I=SJ TO DATACOUNT DO BEGIN
XL:=0;
FOR J=0 TO SJ DO BEGIN
XL:=XL+FC[I-J];
END;
MAN:=XL;
END;
HS:=100*XL/CAPITAL;
WM:=COST(100);
WN:=COST(0);
WP:=100*(WM-WN)/WN;
WG:=WP-REF(WP,1)<2;
WI:=BARSLAST(WG);
WD:=BARSLAST(WI);
WF:=LBOUND(WD);
WT:=IF(SYSPARAM(1)>WF,WD,0);
WHX:=RANGE(BARPOS,SYSPARAM(2),SYSPARAM(1)+1) AND WT>0;
WTS:=WHX AND BARSCOUNT(CLOSE)=SYSPARAM(1) AND WD;
YBH1:=EMA(CLOSE,7)-EMA(CLOSE,19);
YBH2:=EMA(YBH1,9);
YB:=YBH1>=YBH2;
YH:=YBH1>=0;
SZ:=(CLOSE*3+HIGH+LOW+OPEN)/6;
SK:=EMA(SZ,13)-EMA(SZ,73);
SD:=EMA(SK,2);
XH:=CROSS(SK,SD) AND SK<-0.04 AND CLOSE-REF(CLOSE,1)/REF(CLOSE,1)>=0.03 OR CROSS(SK,SD) AND SK<=-0.14 OR CROSS(SK,SD) AND SK<=0.05 AND (VOL/MA(VOL,5)>2 OR CLOSE/REF(CLOSE,1)>0.035);
QJ1:=SUM(VOL*CLOSE,1)/SUM(VOL,1);
QJ2:=EMA(QJ1,13);
QJ3:=FORCAST((QJ1-QJ2)*100/QJ1,5);
XLA:=CLOSE>=REF(CLOSE,1) AND REF(CLOSE,1)>=REF(CLOSE,2) AND REF(CLOSE,1)<=REF(CLOSE,3) AND REF(CLOSE,2)<=REF(CLOSE,3) AND (REF(CLOSE,4)>REF(CLOSE,2) OR REF(CLOSE,4)<=REF(CLOSE,2) AND REF(CLOSE,5)>=REF(CLOSE,3)) OR CLOSE>=REF(CLOSE,1) AND REF(CLOSE,1)<=REF(CLOSE,2) AND CLOSE>=REF(CLOSE,2) AND (REF(CLOSE,3)>REF(CLOSE,1) OR REF(CLOSE,3)<=REF(CLOSE,1) AND REF(CLOSE,4)>=REF(CLOSE,2));
STICKLINE(ZJ6<=0,0,最低+Z/2,5,1),colorFCFF00;
STICKLINE(CD4>0,0,最低+Z/2,5,0),colorFFB0FF;
STICKLINE(CD4>0,0,(最低+Z/2)*0.8,5,0),colorFF8CFF;
STICKLINE(CD4>0,0,(最低+Z/2)*0.6,5,0),colorFF59FF;
STICKLINE(CD4>0,0,(最低+Z/2)*0.4,5,0),colorFF18FF;
STICKLINE(CD4>0,0,(最低+Z/2)*0.2,5,0),color1DFF;
STICKLINE(HZ3,0,最低+Z/2,5,0),colorFF00;
STICKLINE(HZ3,0,(最低+Z/2)*0.8,5,0),color33CC00;
STICKLINE(HZ3,0,(最低+Z/2)*0.6,5,0),color339900;
STICKLINE(HZ3,0,(最低+Z/2)*0.4,5,0),color337700;
STICKLINE(HZ3,0,(最低+Z/2)*0.2,5,0),color5500;
STICKLINE(ZJ6>=0,0,最低+Z/2,5,1),color5050FF;
STICKLINE(CLOSE<铁底,Z/2,最低+Z/2,5,0),color808080;
PARTLINE(CLOSE,高),POINTDOT,color808080;
PARTLINE(CLOSE,中),POINTDOT,color808080;
PARTLINE(CLOSE,低),POINTDOT,colorFFFFFF;
强:FORCAST(XDJ3,5),LINETHICK0,PRECISION2,colorFF;
弱:=FORCAST(REF(XDJ3,1),5);
PARTLINE(CLOSE,强),LINETHICK2,colorFF;
PARTLINE(强<弱,强),LINETHICK2,colorFF0000;
区界:REF(LLV(XDJ3,T2),T1),LINEDOT,PRECISION2,colorFFFF;
换手率:IF(CAPITAL=0,VOL/SUM(VOL,100)*100,VOL/FINANCE(7)),LINETHICK0,PRECISION2,colorFF00FF;
涨跌幅:(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,LINETHICK0,PRECISION2,colorFFBBFF;
GDT2:=FINANCE(0);
XXX:=STRTONUM(STRRIGHT(NUMTOSTR(FINANCE(0),0),2));
NN:=IF(XXX>11 OR XXX<3,1,IF(BETWEEN(XXX,2.9,6),4,IF(BETWEEN(XXX,5.9,9),2,4/3)));
市赢率:CLOSE/(FINANCE(33)*NN),LINETHICK0,PRECISION2,colorFFFF00;
市净率:CLOSE/FINANCE(34),LINETHICK0,PRECISION2,colorFF8500;
DRAWTEXT(XH,强*0.86,' ↑ \n★'),ALIGN0,color89FF;
DRAWTEXT(BARPOS=SYSPARAM(2),高,'高位: '+NUMTOSTR(高,2)),PXUP26,color808080;
DRAWTEXT(BARPOS=SYSPARAM(2),中,'中位: '+NUMTOSTR(中,2)),PXUP26,color808080;
DRAWTEXT(BARPOS=SYSPARAM(2),最低*0.68,'低位: '+NUMTOSTR(低,2)),PXUP8,colorFFFFFF;
PARTLINE(WHX,中*0.9),color8585FF;
DRAWTEXT(WTS,中*0.88,'稳定天数:'+NUMTOSTR(WT[SYSPARAM(1)],0)+'(天) '),ALIGN2,PXDN6,color8585FF;
PARTLINE(RANGE(BARPOS,SYSPARAM(1),SYSPARAM(3)+3),中*(1.1)),color5BBBB5;
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(1),中*1.2,' 倒数: '+NUMTOSTR(B[SYSPARAM(1)],0)+'(天) '+' \n 累计换手:'+NUMTOSTR(HS,2)+'% '),ALIGN2,PXUP18,color5BBBB5;

飞狐保护神指标公式

 

相关文章