在线检测未来函数

飞狐灵泉仙景指标公式

来源:Internet,编辑:股旁网,2014-03-11

DRAWGBK (C, COLORRGB(250,250,250), COLORRGB(000,100,120),1);
换手:VOL/CAPITAL,linethick0,colorgreen;
最高价偏:=ABS(H-REF(C,1));
最低价偏:=ABS(L-REF(C,1));
高低偏:=ABS(H-REF(L,1));
昨K长:=ABS(REF(C,1)-REF(O,1));
偏离度:=IF(最低价偏>MAX(高低偏,最高价偏),最低价偏+最高价偏/2+昨K长/4,高低偏+昨K长/4);
升降度:=C+(C-O)/2-REF(O,1);
WHK调节系数:=升降度/偏离度;
波动量:=WHK调节系数*MAX(最高价偏,最低价偏);
波动量积累:=SUM(波动量,0);
均波动量积累:=eMA(波动量积累,125);
波动线:=(波动量积累-均波动量积累)/50;
波动线a:=波动线/2;
FILLRGN(NOT(波动线>0),0,波动线a-波动线a*0.75),Color004F00;
FILLRGN(NOT(波动线>0),波动线a-波动线a*0.75,波动线a-波动线a*0.5),Color007600;
FILLRGN(NOT(波动线>0),波动线a-波动线a*0.5,波动线a-波动线a*0.25),Color00AD00;
FILLRGN(NOT(波动线>0),波动线a,波动线a-波动线a*0.25),Color00DE00;
FILLRGN(波动线>0 AND 波动线>=REF(波动线,1),0,波动线),ColorA1E5FF;
FILLRGN(波动线>0 AND 波动线<REF(波动线,1),0,波动线),Color4A7AB7;
综价:=(H+L+O+C)/4;
资金:=MA((winner(c*0.97)-winner(c*0.9))*c,5)/120;
长资金:=WMA((winner(c*0.9)-winner(c*0.5))*c,5)/120;
筹码锁定:=长资金>短资金 AND MA(C,10)>=REF(MA(C,10),1);
锁筹拉升:筹码锁定 AND WMA(C,5)>=REF(WMA(C,5),1) AND 长资金>REF(长资金,1),ColorFFA9FF,linethick0;
FILLRGN(筹码锁定,长资金,短资金),ColorFF6E98;
FILLRGN(锁筹拉升,长资金,短资金),ColorFFA9FF;
FILLRGN(NOT(筹码锁定),长资金,短资金),Color007700;
FILLRGN(NOT(筹码锁定) AND 长资金>短资金,长资金,短资金),Color994444;
锁拉开始:锁筹拉升 AND COUNT(锁筹拉升,2)=1,linethick0,ColorFFAAFF;
FILLRGN(c,MIN(短资金,长资金),0),Color003A00;
获利比:=WINNER(C);
获利比M5:=WMA(获利比,5);
获利筹:=EMA(获利比,21);
获利筹M5:=EMA(获利筹,5);
获利比M100:=EMA(获利比,100);
浮动筹:=MA(WINNER(C*1.05)-WINNER(C*0.95),6);
做多条件:=MA(综价,5)>MA(C,21) AND MA(C,10)>=REF(MA(C,10),1);
三成获利拉升:=获利筹>获利筹M5 AND 获利筹>0.3;
低吸获利拉升:=获利筹>获利筹M5 AND 获利筹<0.3 AND 获利筹>获利比M100;
控盘拉升:=获利比M5>浮动筹 AND 做多条件 OR 锁筹拉升;
做多:三成获利拉升 OR 低吸获利拉升 OR 控盘拉升,linethick0,Color11ffff;
搏傻:获利比M5>0.7 AND 做多,linethick0,ColorDBD900;
拼搏:获利比M5>0.8 AND 做多,linethick0,Color006600;
冲剌:获利比M5>0.9 AND 做多,linethick0,Color009900;
金顶:波动线>MAX(短资金,长资金) AND 波动线>=REF(波动线,1) AND 做多,Color0060FF,linethick0;
FILLRGN(金顶,波动线,波动线*0.85),Color0060FF;
FILLRGN(波动线>MAX(短资金,长资金) AND 波动线<REF(波动线,1) AND 搏傻,波动线,波动线*0.85),Color00327D;
STICKLINE(NOT(做多),-换手/400,0,6,0),COLOR003300;
STICKLINE(做多,-换手/400,0,6,0),COLOR000066;
MAV20:MA(换手,20),coloryellow,linedot;
放量:换手>=MAV20,COLORwhite,linethick0;
STICKLINE(放量,-换手/400,-MAV20/400,6,0),COLORaaaaaa;
STICKLINE(做多,换手/400,0,6,0),Color000071;
STICKLINE(做多,换手/400,0,5.5,0),Color0000C3;
STICKLINE(做多,换手/400,0,4.5,0),Color0027FF;
STICKLINE(做多,换手/400,0,3,0),Color0033C8;
STICKLINE(做多,换手/400,0,1,0),Color008EFF;
STICKLINE(NOT(做多),换手/400,0,8,0),Color002200;
STICKLINE(NOT(做多),换手/400,0,7.5,0),Color005500;
STICKLINE(NOT(做多),换手/400,0,5,0),Color007700;
STICKLINE(NOT(做多),换手/400,0,3.5,0),Color00aa00;
STICKLINE(NOT(做多),换手/400,0,1.5,0),Color00FF00;
STICKLINE(c,0,-0.0005,10,0),Color003300;
STICKLINE(做多,-0.0005,-0.002,10,0),COLOR66ffff;
STICKLINE(搏傻,-0.002,-0.0045,10,0),COLORDBD900;
STICKLINE(拼搏,-0.0025,-0.005,10,0),COLOR004400;
STICKLINE(冲剌,-0.0045,-0.007,10,0),Color00dd00;

飞狐灵泉仙景指标公式

 

相关文章