在线检测未来函数

同花顺多空能量指标公式

来源:Internet,编辑:股旁网,2014-04-08

MVAR6:=REF(LOW,1)*0.9;
MVAR7:=LOW*0.9;
MVAR10:=(MVAR7*VOL+MVAR6*(CAPITAL-VOL))/CAPITAL;
MVAR11:=EMA(MVAR10,30);
MVAR12:=CLOSE-REF(CLOSE,1);
MVAR13:=MAX(MVAR12,0);
MVAR14:=ABS(MVAR12);
MVAR15:=SMA(MVAR13,7,1)/SMA(MVAR14,7,1)*100;
MVAR16:=SMA(MVAR13,13,1)/SMA(MVAR14,13,1)*100;
MVAR17:=BARSCOUNT(CLOSE);
MVAR18:=SMA(MAX(MVAR12,0),6,1)/SMA(ABS(MVAR12),6,1)*100;
MVAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
MVAR20:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
MVAR21:=SMA((SMA(MVAR20,4,1)-50)*2,3,1);
MVAR22:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
MVAR23:=SMA(MVAR22,4,1);
MVAR24:=SMA(MVAR23,3,1);
MVAR25:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
打压建仓:MVAR18<=25 AND MVAR19<-95 AND MVAR25>20 AND MVAR21<-30 AND MVAR24<30 AND MVAR11-CLOSE>=-0.25 AND MVAR15<22 AND MVAR16<28 AND MVAR17>50,colorred ;
抄底:IF((C-MIN(REF(C,2)*0.865,REF(C,13)*0.772))/C<0.1 AND SUM(100*VOL/CAPITAL,5)/5<1.8,-5, 0),Color00FF00,LINETHICK0;
抛压:CROSS(84,SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100),colorgreen,LINETHICK0;
资金:(((100-3*SMA((CLOSE-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,66))/
(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1))<REF((100-3*SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*
100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1)),1) AND VOL>REF(VOL,1) AND
CLOSE>REF(CLOSE,1)) AND COUNT(((100-3*SMA((CLOSE-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1)+2*
SMA(SMA((CLOSE-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1))<REF((100-3*SMA((OPEN-LLV(LOW,66))/
(HHV(HIGH,66)-LLV(LOW,66))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),15,1)),1) AND
VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1)),30)=1),colorred,LINETHICK0;
MVAR43:=((AMOUNT)/(VOL))/(100);
MVAR44:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
MVAR45:=((SUM(AMOUNT,7))/(MVAR43))/(100);
MVAR46:=DMA(MVAR44,(VOL)/(MVAR45));
MVAR47:=((CLOSE-MVAR46)/(MVAR46))*(100);
MVAR48:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
MVAR49:=MA(MVAR47,20)+STD(MVAR47,20);
MVAR50:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
MVAR51:=SMA(MVAR48,3,1);
风险:(REF(MVAR50,1)>=5 AND CROSS(MVAR49,MVAR47) AND MVAR51>79),colorgreen;
拉台:FILTER(C/REF(C,1)>1.028 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12)),28)*100
AND L>REF(C,1)*0.93 ,colorred;
多方:=SMA((CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*400,3,1);
STICKLINE(多方<REF(多方,1)AND 多方>0,0,多方,4,0),COLOR0000AA;
STICKLINE(多方<REF(多方,0.5)AND 多方>0,0,多方,3.5,0),COLOR000095;
STICKLINE(多方<REF(多方,0.5)AND 多方>0,0,多方,3,0),COLOR0000A2;
STICKLINE(多方<REF(多方,1)AND 多方>0,0,多方,2.5,0),COLOR0000B3;
STICKLINE(多方<REF(多方,1)AND 多方>0,0,多方,2,0),COLOR0000C8;
STICKLINE(多方<REF(多方,0.5)AND 多方>0,0,多方,1.5,0),COLOR0000D7;
STICKLINE(多方<REF(多方,0.5)AND 多方>0,0,多方,1,0),COLOR0000EA;
STICKLINE(多方<REF(多方,1)AND 多方>0,0,多方,0.5,0),COLOR0000FF;
STICKLINE(多方>REF(多方,1)AND 多方>0,0,多方,8,0),COLOR0000AA;
STICKLINE(多方>REF(多方,1)AND 多方>0,0,多方,7,0),COLOR000095;
STICKLINE(多方>REF(多方,1)AND 多方>0,0,多方,6,0),COLOR0000A2;
STICKLINE(多方>REF(多方,1)AND 多方>0,0,多方,5,0),COLOR0000B3;
STICKLINE(多方>REF(多方,1)AND 多方>0,0,多方,4,0),COLOR0000C8;
STICKLINE(多方>REF(多方,1)AND 多方>0,0,多方,3,0),COLOR0000D7;
STICKLINE(多方>REF(多方,1)AND 多方>0,0,多方,2,0),COLOR0000EA;
STICKLINE(多方>REF(多方,1)AND 多方>0,0,多方,1,0),COLOR0000FF;
STICKLINE(多方<REF(多方,1)AND 多方<0,0,-多方,8,0),COLOR007700;
STICKLINE(多方<REF(多方,1)AND 多方<0,0,-多方,7,0),COLOR008E00;
STICKLINE(多方<REF(多方,1)AND 多方<0,0,-多方,6,0),COLOR009900;
STICKLINE(多方<REF(多方,1)AND 多方<0,0,-多方,5,0),COLOR00A600;
STICKLINE(多方<REF(多方,1)AND 多方<0,0,-多方,4,0),COLOR00B500;
STICKLINE(多方<REF(多方,1)AND 多方<0,0,-多方,3,0),COLOR00C600;
STICKLINE(多方<REF(多方,1)AND 多方<0,0,-多方,2,0),COLOR00D500;
STICKLINE(多方<REF(多方,1)AND 多方<0,0,-多方,1,0),COLOR00E600;
STICKLINE(多方>REF(多方,1)AND 多方<0,0,-多方,4,0),COLOR007700;
STICKLINE(多方>REF(多方,1)AND 多方<0,0,-多方,3.5,0),COLOR008800;
STICKLINE(多方>REF(多方,1)AND 多方<0,0,-多方,3,0),COLOR008E00;
STICKLINE(多方>REF(多方,1)AND 多方<0,0,-多方,2.5,0),COLOR009900;
STICKLINE(多方>REF(多方,1)AND 多方<0,0,-多方,2,0),COLOR00A600;
STICKLINE(多方>REF(多方,1)AND 多方<0,0,-多方,1.5,0),COLOR00B500;
STICKLINE(多方>REF(多方,1)AND 多方<0,0,-多方,1,0),COLOR00C600;
STICKLINE(多方>REF(多方,1)AND 多方<0,0,-多方,0.7,0),COLOR00D500;
STICKLINE(多方>REF(多方,1)AND 多方<0,0,-多方,0.5,0),COLOR00E600;
STICKLINE(抛压,多方 ,多方+多方/8,8,0),COLORFF0044;
STICKLINE(抛压,多方 ,多方+多方/8,7,0),COLORff0055;
STICKLINE(抛压,多方 ,多方+多方/8,6,0),COLORff0066;
STICKLINE(抛压,多方 ,多方+多方/8,5,0),COLORff0077;
STICKLINE(抛压,多方 ,多方+多方/8,4,0),COLORFF0088;
STICKLINE(抛压,多方 ,多方+多方/8,3,0),COLORff0099;
STICKLINE(抛压,多方 ,多方+多方/8,2,0),COLORff00aa;
STICKLINE(抛压,多方 ,多方+多方/8,1,0),COLORff00bb;
STICKLINE(大资金,ABS(多方) ,ABS(多方/3),11,0),COLOR106FFF;
STICKLINE(大资金,ABS(多方) ,ABS(多方/3),10,0),COLOR000095;
STICKLINE(大资金,ABS(多方) ,ABS(多方/3),9,0),COLOR00AAFF;
STICKLINE(大资金,ABS(多方) ,ABS(多方/3),7,0),COLOR00BBFF;
STICKLINE(大资金,ABS(多方) ,ABS(多方/3),5,0),COLOR00CCFF;
STICKLINE(大资金,ABS(多方) ,ABS(多方/3),3,0),COLOR00DDFF;
STICKLINE(大资金,ABS(多方) ,ABS(多方/3),2,0),COLOR00EEFF;
STICKLINE(大资金,ABS(多方) ,ABS(多方/3),1,0),COLOR00FFFF;
STICKLINE(打压建仓,ABS(多方),ABS(多方)-3,10,0),colorred ;
STICKLINE(抄底,0,3,10,0),ColorFFFFFF;
DRAWTEXT(抄底 ,0,'短'),colorgreen;
DRAWTEXT(抄底 ,-2,'底'),colorgreen;
DRAWTEXT(拉台 ,0,'拉'),colorred;
DRAWTEXT(拉台 ,-2,'台'),colorred;
DRAWTEXT(风险,多方,'风险'),colorgreen;
DRAWTEXT((大资金=1),-1,'大资金'),coloryellow;
量均:=EMA(VOL,13);
额均:=EMA(AMOUNT,13);
比A:=额均/量均/100;
价变:=(CLOSE-比A)/比A*100;
量变:=EMA(VOL/CAPITAL*100,13);
量价升:((量变>REF(量变,1) AND 额均>REF(额均,1) AND 价变>REF(价变,1) AND 多方>REF(多方,1) ));
一星级:=量变>0 AND 价变>5 AND 多方>0 AND 多方>REF(多方,1);
二星级:=量变>1 AND 价变>5 AND 多方>0 AND 多方>REF(多方,1);
三星级:=量变>3 AND 价变>5 AND 多方>0 AND 多方>REF(多方,1);
四星级:=量变>5 AND 价变>5 AND 多方>0 AND 多方>REF(多方,1);
STICKLINE(四星级,ABS(多方/2) ,0 ,2 ,0 ),colorblack;
STICKLINE(三星级,ABS(多方/3) ,0,3 ,0 ),coloryellow;
STICKLINE(二星级,ABS(多方/5),0 ,5 ,0 ),colorcyan;
STICKLINE(一星级,ABS(多方/9) ,0 ,7 ,0 ),colorblue;
STICKLINE(量价升,ABS(多方/9) ,0 ,3 ,0 ),coloryellow;

同花顺多空能量指标公式

 

相关文章