在线检测未来函数

通达信MACD分时主图指标公式

来源:Internet,编辑:股旁网,2014-04-28

ZRS:=CONST(DYNAINFO(3)),NODRAW;
A1:=3.5*(EMA(CLOSE,12)-EMA(CLOSE,26))+ZRS,COLORLIMAGENTA;
A2:=EMA(A1,9),COLORLIBLUE;
MACD:=(A1-A2)*2+ZRS;
DRAWKLINE(H,O,L,C);
STICKLINE(A1>=A2,ZRS,MACD ,0,1),COLORRED;
STICKLINE(A1<A2,ZRS,MACD ,0,1),COLORCYAN;
C,COLORWHITE,LINETHICK2;
均价:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINETHICK1;
IF(均价<=REF(均价,1),均价,DRAWNULL),COLORGREEN,LINETHICK3;
IF(均价>=REF(均价,1),均价,DRAWNULL),COLORYELLOW,LINETHICK3;
DRAWTEXT(CURRBARSCOUNT=4,均价,'均'),COLORYELLOW,LINETHICK3;
DRAWNUMBER(CURRBARSCOUNT=2,均价,均价),COLORYELLOW,LINETHICK3;
DRAWTEXT_FIX(1,0.000,1-0.05,0,DYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.0550,1-0.05,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.1050,1-0.05,0,GNBLOCK),COLORYELLOW;

通达信MACD分时主图指标公式

 

相关文章