在线检测未来函数

飞狐改进型MACD指标公式

来源:Internet,编辑:股旁网,2014-06-22

p:=26;
p2:=3;
s:=12;
m:=9;
DIFF : EMA(CLOSE,s) - EMA(CLOSE,p),colorred,linethick2;
DEA : EMA(DIFF,m),linethick0;
MACD : 3*(DIFF-DEA), COLORSTICK,linethick2;
PARTLINE(diff<=ref(diff,1),diff),Colorgreen,linethick2;
k:0;
k2:if(diff>0,hhv(diff,p2),llv(diff,p2));
STICKLINE(((macd<REF(macd,1)) AND (macd>0)),0,macd,1,0),COLOR00cfff,LINETHICK2;
STICKLINE(((macd>REF(macd,1)) AND (macd<0)),0,macd,1,0),COLORFF00FF,LINETHICK2;

飞狐改进型MACD指标公式

 

相关文章