在线检测未来函数

通达信愚公未来信号指标公式

来源:Internet,编辑:股旁网,2014-06-27

F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
S1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;
S2:=今小前;
A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));
A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1));
A3:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1));
STICKLINE(A1 AND A2 ,0,3,3,0)COLORGREEN;
STICKLINE(A1 AND A2 ,0,1,3,0)COLORYELLOW;
STICKLINE(A1 AND A2 AND A3,0,5,3,0)COLORRED;
STICKLINE(A1 AND A2 AND A3,0,3,3,0)COLORGREEN;
STICKLINE(A1 AND A2 AND A3,0,1,3,0)COLORYELLOW;

通达信愚公未来信号指标公式

 

相关文章