在线检测未来函数

大智慧强势牛股主图指标公式

来源:Internet,编辑:股旁网,2014-07-16

N:=10;
P:=3;
BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,LINETHICK2;
UPR:BBI+P*STD(BBI,N);
DWN:BBI-P*STD(BBI,N);
EMA5:EMA(CLOSE,5);
W:=BARSLAST(DISPSTATUS=1);
天:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
DRAWTEXTREL(10,150,'■目前可见K线:'+NUMTOSTRN(W+1,0)+'天'),colorwhite;
低涨:(C/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;DRAWTEXTREL(10,100,'■低点至今上涨:'+NUMTOSTRN(低涨,2)+'% '+NUMTOSTRN(天,0)+'天'),COLOR0000FF;
DRAWTEXTREL(10,200,'■建议查阅K线:短线30天,中长线120天!'),COLORFF8899;
BEGIN DRAWTEXTREL(10,50,'所属板块:'+BKNAME),LINETHICK1,color00FFFF;end;
ZT:=C/REF(C,1)>1.097;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
STICKLINE(ZT,REF(O,BH),REF(C,BH),7,0),COLORYELLOW;
TY:=C;
A1:=REF(TY,5)=HHV(TY,2*5+1); B1:=FILTER(A1,5); C1:=BACKSET(B1,5+1); HD:=FILTER(C1,5);
A2:=REF(TY,5)=LLV(TY,2*5+1); B2:=FILTER(A2,4); C2:=BACKSET(B2,4+1); LD:=FILTER(C2,5);
压力线:REF(C,BARSLAST(HD)),COLORRED{红色},POINTDOT;
STICKLINE(C,压力线,压力线,8,2),COLORMAGENTA{红色},linethick1;

大智慧强势牛股主图指标公式

 

相关文章