在线检测未来函数

通达信DMI背离指标公式

来源:Internet,编辑:股旁网,2014-07-16

N:=21;
M:=6;
M1:=20;
TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),N);
DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),N);
PDI:= DMP*100/TR1;
MDI:= DMM*100/TR1;
ADX: EMA((PDI-MDI)/(MDI+PDI)*100,M)*2;
ADXR:EMA(ADX,M);
ADMA:EMA(ADX,M1);
OMD:(ADX-2*ADMA+ADXR)/2, COLORSTICK;
DRAWBAND(ADX,RGB(155,50,50),ADXR,RGB(0,100,50));
STICKLINE(OMD>REF(OMD,1) AND OMD>0,0,OMD,1,0),COLORRED;
STICKLINE(OMD>REF(OMD,1) AND OMD<0,0,OMD,1,0),COLORGREEN;
STICKLINE(OMD<REF(OMD,1),0,OMD,1,0),COLORCBCBC0;
STICKLINE(OMD>=0 OR OMD<=0,0,0,50,1),COLORWHITE;
ADX1:ADX,COLORRED;
ADXR1:ADXR,COLORGREEN;
ADMA1:ADMA;
强:IF(ADX1>=ADXR1,ADX1,DRAWNULL),COLORRED,LINETHICK3;
买入:IF(OMD>0 AND OMD-REF(OMD,1)>0,30,0);
A1:=BARSLAST(REF(CROSS(ADX,ADXR),1));
B1:=REF(C,A1+1)>C AND REF(ADXR,A1+1)<ADXR AND CROSS(ADX,ADXR);
DRAWTEXT(B1>0,ADX-0.1,'底背离'),COLORFF00FF;
STICKLINE(B1,0,ADX,0.5,0),COLOR0000FF;
C1:=BARSLAST(REF(CROSS(ADXR,ADX),1));
D1:=REF(C,C1+1)<C AND REF(ADX,C1+1)>ADX AND CROSS(ADXR,ADX);
DRAWTEXT(D1> 0,ADX+0.1,'顶背离'),COLOR00FF00;
STICKLINE(D1,0,ADX,0.5,0),COLOR00FFFF;
110;
0;
-110;

通达信DMI背离指标公式

 

相关文章